Jump to content


Photo

DVI/VGA Outputs on 6970 and Tv (problem)


  • Please log in to reply
19 replies to this topic

#1 tristan-117

tristan-117

    Learner

  • Quark
  • 54 posts

Posted 04 April 2012 - 06:46 AM

I recently bought a Blu Ray drive for my computer and two new cables; a Male-to-male aux cord and a vga cable. These cables go from the back of my computer to a Samsung 32in LCD. The sound works perfectly fine, however the vga cable is hell. The back of my 6970 has 2 dvi outs, hdmi out and a few mini display ports. I chose VGA over HDMI because I believe it provides a better image on a TV, text etc looks so much more crisp and so do colors. Obviously because I have only DVI out I have to use an adapter. I started by unplugging the current cable from my gfx card, so now it was connected to nothing. then I attached the new vga cable and it displayed on my TV - perfect. Then I attached my computer monitor and it switched to that and stopped displaying on my TV. Now, I have done EVERYTHING there is to do in catalyst and screen resolution and what not to manually change the output setting to TV, but no matter what I do it never displays on the tv unless I unplug my monitor and tv then reattach the tv to the gfx. Otherwise as soon as my monitor is plugged in, the gfx card always outputs to the monitor and nothing else. I want to be able to switch outputs to TV whenever I feel like it to watch Blu-Rays but i have to keep getting behind my computer and switching cables to do it. Please help.

#2 aliali

aliali

    Titan

  • Super Hero
  • 23,567 posts

Posted 04 April 2012 - 09:12 AM

I chose VGA over HDMI because I believe it provides a better image on a TV, text etc looks so much more crisp and so do colors.

Seriously?
Just use HDMI dude, it's what it is designed for, especially as it carries both the video and audio in one cable.
She's going to be really smart, very savvy, haunting good looks, really good at her job. And kind of slutty.

#3 NukeJockey

NukeJockey

    Titan

  • Hero
  • 23,615 posts

Posted 04 April 2012 - 12:14 PM

I recently bought a Blu Ray drive for my computer and two new cables; a Male-to-male aux cord and a vga cable. These cables go from the back of my computer to a Samsung 32in LCD. The sound works perfectly fine, however the vga cable is hell. The back of my 6970 has 2 dvi outs, hdmi out and a few mini display ports. I chose VGA over HDMI because I believe it provides a better image on a TV, text etc looks so much more crisp and so do colors. Obviously because I have only DVI out I have to use an adapter.

I started by unplugging the current cable from my gfx card, so now it was connected to nothing. then I attached the new vga cable and it displayed on my TV - perfect. Then I attached my computer monitor and it switched to that and stopped displaying on my TV. Now, I have done EVERYTHING there is to do in catalyst and screen resolution and what not to manually change the output setting to TV, but no matter what I do it never displays on the tv unless I unplug my monitor and tv then reattach the tv to the gfx. Otherwise as soon as my monitor is plugged in, the gfx card always outputs to the monitor and nothing else. I want to be able to switch outputs to TV whenever I feel like it to watch Blu-Rays but i have to keep getting behind my computer and switching cables to do it.
Please help.


There are options in CCC, more specifically, you'd be looking at an option to change your primary monitor. It may also be worth reading your TVs manual, most Samsung TVs have a dedicated PC channel, usually on HDMI 1 or something.
My Rig: ASUS P67 Sabretooth | i5 2500k w/ Corsair H80 | 8gb G.Skill Ripjaw-X 1866mhz | Sapphire R9 290 Tri-X| NZXT Phantom | Corsair HX850

#4 blackmancer

blackmancer

    Master

  • Atomican
  • 750 posts

Posted 10 April 2012 - 07:25 AM

yeah I'd say setting the primary display is what you're after (while they are both plugged in). within display properties in control panel, not in CCC.

Edited by blackmancer, 10 April 2012 - 07:29 AM.

BLACKSTACK - Corsair 800D, HX-850, i5-3330, 4x4G Corsair1600, ASUS Sabertooth Z77, Powercolor 7950PCS+, 2x180GB Intel330 SSD (R0), 2x1TB WD Black (R1), 2x2TB WD Green (R1)

#5 tristan-117

tristan-117

    Learner

  • Quark
  • 54 posts

Posted 13 April 2012 - 10:45 AM

Alright I did as you guys said and it worked great, thank you. However another, more minor problem is occurring. Every time I switch to my TV, the picture is always to far to the left, I get a black bar on the right and the left side is cut of and I have to go to CCC to adjust it back, EVERY.SINGLE.TIME. Is there any way to avoid this, I am certain It's because I'm using a DVI port out of my gfx card and adapting that to VGA (so digital converted to analogue).

Seriously?
Just use HDMI dude, it's what it is designed for, especially as it carries both the video and audio in one cable.


Well, try it yourself. Maybe the laptop I tested HDMI with was not very good at handling those resolutions but it provided a terrible image. VGA doesn't, everything is clear and the color palette is huge.

#6 aliali

aliali

    Titan

  • Super Hero
  • 23,567 posts

Posted 13 April 2012 - 11:12 AM

Well, try it yourself. Maybe the laptop I tested HDMI with was not very good at handling those resolutions but it provided a terrible image. VGA doesn't, everything is clear and the color palette is huge.

Just set up a customers desktop with HDMI to his TV via HDMI and his monitor is still connected via DVI. Works fine so long as you don't create a display group through eyefinity.
It is just set up to clone the desktop (same display on each screen).
Your problem may be to do with different native resolutions between the two screens?
Check the specs of each.
I also run my HTPC to my TV via HDMI only (only the tv connected).
Colour palette should be identical on HDMI so sounds like you have a setting wrong or a driver issue, and as NukeJockey suggested try different HDMI inputs on the TV.

If I remember I will try my Dell Studio 1555 (ATI GFX) on the TV and see what happen (think both run 1920x1080 res from memory).

What make and model monitor do you have and what model Samsung TV?

Edited by aliali, 13 April 2012 - 11:15 AM.

She's going to be really smart, very savvy, haunting good looks, really good at her job. And kind of slutty.

#7 tristan-117

tristan-117

    Learner

  • Quark
  • 54 posts

Posted 13 April 2012 - 05:06 PM

Both screens are 1920 x 1080. The TV is a Samsung 32in. The monitor is AOC 23.5 in. I use other devices connected to the TV's HDMI ports (xbox, tivo) and they are fine. But when I tried my old laptop on it using HDMI the picture was pretty bad. And I don't think sound will travel through HDMI with my computer because sound won't go out a gfx card will it? My problem is just the picture alignment when i switch to my TV.

#8 aliali

aliali

    Titan

  • Super Hero
  • 23,567 posts

Posted 13 April 2012 - 11:08 PM

Both screens are 1920 x 1080.
The TV is a Samsung 32in. The monitor is AOC 23.5 in. I use other devices connected to the TV's HDMI ports (xbox, tivo) and they are fine. But when I tried my old laptop on it using HDMI the picture was pretty bad.

Then I would bet it was to do with the laptop graphics card.

And I don't think sound will travel through HDMI with my computer because sound won't go out a gfx card will it?

Yes it does, so long as the GFX card is designed right. That's the point of HDMI.
ATI cards (at least) have a sound card built in for this. Shows up in device manager under "sounf video and game controllers' as ATI HDMI Audio.
This has been the case since at least the 4 series cards (can't remember if the 3 series had this).

HDMI (High-Definition Multimedia Interface) is a compact audio/video interface for transferring encrypted uncompressed digital audio/video data from a HDMI compliant device ("the source" or "input") to a compatible digital audio device, computer monitor, video projector, and digital television.
http://en.wikipedia.org/wiki/HDMI

This is how I have my HTPC hooked up just the HDMI cable from the AMD FM1s integrated HD6410D video card, this provides both video and audio to the Kogan TV.

My problem is just the picture alignment when i switch to my TV.

Then most likely it is the same issue I had when setting up the aforementioned customers system.
I mistakenly made a display group under the Eyefinity stuff in the AMD control centre and half the display was on the PC and the other half on the TV with half the screen on each display being blank. Deleting the monitor group fixed it.

Otherwise it is most likely the issue is because you are outputting to both DVI ports with one going via the DVI to VGA converter. Would not surprise me if the issue goes away if you use the HDMI port (assuming the display group thing is not the issue).

Ok just tried out my Dell Studio 1555 notebook (HD 4570) on my Kogan TV and it worked fine via HDMI. Now the drivers I have installed do not support Eyefinity so by using the Fn + F1 keys on the laptop I can switch between disconnect projector (tv actually), Duplicate (same output to both screens), extend (bigger desktop across both screens) or projector (TV) only. All worked ok for me with the Tv being fine colour and clarity wise.

Also worth noting that some BD movies may not work going through the DVI to VGA adapter because it breaks the whole High-bandwidth Digital Content Protection crap that a lot of BD disks have.
She's going to be really smart, very savvy, haunting good looks, really good at her job. And kind of slutty.

#9 tristan-117

tristan-117

    Learner

  • Quark
  • 54 posts

Posted 16 April 2012 - 01:52 PM

Oh the Blu-Rays go through just fine. I think I'll return the vga cable and go for HDMI. It has nothing to do with the eyefinity settings. This has happened on a previous computer that I used a DVI to VGA adapter, picture alignment is always just a little bit off and has to be corrected every single time. My only problem now is if the store will accept a refund for the cables.

#10 aliali

aliali

    Titan

  • Super Hero
  • 23,567 posts

Posted 16 April 2012 - 04:11 PM

Oh the Blu-Rays go through just fine. I think I'll return the vga cable and go for HDMI. It has nothing to do with the eyefinity settings. This has happened on a previous computer that I used a DVI to VGA adapter, picture alignment is always just a little bit off and has to be corrected every single time.

My only problem now is if the store will accept a refund for the cables.

Interesting on the BDs as I thought the HDCP shit would spit the dummy about VGA unless you are lucky and all the BD media you have does not "feature" HDCP, or you are running something like AnyDVDHD to strip it out.
As for the

This has happened on a previous computer that I used a DVI to VGA adapter

mm sounds like it is an adapter issue then.
If you get a new HDMI cable make sure to get one that is V 1.4 compliant.
http://en.wikipedia....DMI#Version_1.4
She's going to be really smart, very savvy, haunting good looks, really good at her job. And kind of slutty.

#11 tristan-117

tristan-117

    Learner

  • Quark
  • 54 posts

Posted 17 April 2012 - 08:14 PM

Oh yes I forgot to mention I have AnyDVD HD running. All the Blu Rays I've bought are either Region 2 or Region free, most of which are the latter. But I'm certain they all work through the cable for whichever reason. So it looks like I'm back to the Computer Fair...

#12 aliali

aliali

    Titan

  • Super Hero
  • 23,567 posts

Posted 18 April 2012 - 11:04 AM

Oh yes I forgot to mention I have AnyDVD HD running. All the Blu Rays I've bought are either Region 2 or Region free, most of which are the latter. But I'm certain they all work through the cable for whichever reason.

So it looks like I'm back to the Computer Fair...

AnyDVD FTW. :P.
Be a bit cautious of Computer Fair cables, they often have really cheap shite that is poorly made.
While a cable should be a cable some of the really cheap ones have poor shielding, poor quality metal and small gauge wire which can affect the video signal quality. You don't have to go to the stupid extreme of the waaaaay overpriced Monster brand, but just be a bit wary of any that are very cheap.
Can't really advise on brands as I have only used a couple of Astrotek cables which seem acceptable to me.
She's going to be really smart, very savvy, haunting good looks, really good at her job. And kind of slutty.

#13 blackmancer

blackmancer

    Master

  • Atomican
  • 750 posts

Posted 22 April 2012 - 01:36 AM

I'd double check the resolution setting for the tv in CCC/Windows Display, also check the refresh while you're there - 50/60Hz
BLACKSTACK - Corsair 800D, HX-850, i5-3330, 4x4G Corsair1600, ASUS Sabertooth Z77, Powercolor 7950PCS+, 2x180GB Intel330 SSD (R0), 2x1TB WD Black (R1), 2x2TB WD Green (R1)

#14 tristan-117

tristan-117

    Learner

  • Quark
  • 54 posts

Posted 22 April 2012 - 01:26 PM

OK I've said it a number of times now, both displays are 1920 x 1080 exactly. I'm not stupid enough to get that mixed up. Both displays are 60Hz. I returned the VGA cable and bought a HDMI cable and honestly, my initial attitude towards HDMI stands. The quality is terrible compared to the VGA cable: colors are more saturated, the palette is smaller, the image doesn't even fit properly on the TV, it's out on every edge. The clarity is less. I don't understand why everyone was so encouraging of HDMI, it can't be my gfx card since it is a Radeon HD 6970 2gb and produces a PERFECT image on my monitor and before when I had the VGA cable, produced a PERFECT image on the TV aside from the image alignment being too far to the left everything else was fine. But now, it's over scanned, colors are worse, there are less colors, red is bleeding onto other pixels, the image doesn't fit it's way too big and even after I under scanned it to fit, all the edges aren't equal to each other. It can't be the HDMI cable as I bought one that cost over $100. Also, I can't seem to duplicate the displays, everytime I try I get "Unable to save settings". I have to either output to DVI or to HDMI, never both at same time.

Edited by tristan-117, 22 April 2012 - 01:32 PM.


#15 aliali

aliali

    Titan

  • Super Hero
  • 23,567 posts

Posted 22 April 2012 - 06:01 PM

Ok well something is seriously screwed up, either with your TV settings or video card settings.
I assume you are running some recent version of the ATI drivers and not the default windows ones.
TV wise the only setting I changed was to go from Overscan > digital tv to overscan > PC settings. Again this is on a Kogan not a Samsung TV (gave my old 32" 720P Samsung to my brother).
Loss of colour palette especially points me to wrong drivers or broken drivers as HDMI V 1.3 onwards can do 48bit colour depth.
Version 1 to 1.2A can only do 24bit.
Should be running the Catalyst 12.3s for that card.
Also worth installing the Hydravision package and possibly the AMD Media Codec Package as well.

/edit
Couple of things I forgot. You must run through the "clear type" and preferably also the "calibrate colour" options in Control Panel\All Control Panel Items\Display.
Without Clear Type calibrated text does look quite crap on large displays.

Edited by aliali, 23 April 2012 - 02:12 PM.

She's going to be really smart, very savvy, haunting good looks, really good at her job. And kind of slutty.

#16 tristan-117

tristan-117

    Learner

  • Quark
  • 54 posts

Posted 23 April 2012 - 08:36 PM

Well after much research, reading manuals etc I finally found a solution and this is important for everyone who plans on using their PC on a TV. The HDMI port you use on your TV IS important! Specifically, Samsung televisions call the first HDMI port a special name: "HDMI(DVI)". The PC must be connected using that Port. THEN, go to the source list on the tv and choose the option "edit name". Choose HDMI(DVI) 1 and name it "PC". Immediately the screen adjusts and everything is centered perfectly, the colors are immaculate and text looks incredibly clear. This does not change the name HDMI(DVI) 1 , it changes the name written afterwards from this: "HDMI(DVI) ---" to "HDMi(DVI) PC". This can be done for other inputs (eg. "AV 1 VCR", or HDMI 2 Blu-Ray Player" etc). After more research, I found out that the reason it because a HDMI(DVI) port uses RGB and is designed for computer connection when PC is selected as the input name, and the other HDMi inputs (HDMI 2, HDMI 3, HDMI 4) use Y Pb/Cb Pr/Cr. However, I would love more replies people have that might explain that difference a little further and why the port is named HDMI(DVI). But the problem is solved. Thanks everyone for your help and fast responses, I hope we all learned a little.

#17 aliali

aliali

    Titan

  • Super Hero
  • 23,567 posts

Posted 23 April 2012 - 11:49 PM

After more research, I found out that the reason it because a HDMI(DVI) port uses RGB and is designed for computer connection when PC is selected as the input name, and the other HDMi inputs (HDMI 2, HDMI 3, HDMI 4) use Y Pb/Cb Pr/Cr.

However, I would love more replies people have that might explain that difference a little further and why the port is named HDMI(DVI). But the problem is solved. Thanks everyone for your help and fast responses, I hope we all learned a little.

MM interesting. Must confess I never tried a PC on the old Samsung TV just used a TVix PVR. The Kogan does not seem to bother with this "fluffing" around as I tried the notebook on HDMI 1 and HDMI 3 and both worked fine for me.
Glad you have it sorted out, so now you can sit back and watch nice HD large screen video content.
:-)
She's going to be really smart, very savvy, haunting good looks, really good at her job. And kind of slutty.

#18 tristan-117

tristan-117

    Learner

  • Quark
  • 54 posts

Posted 25 April 2012 - 09:15 PM

Everything is working great, although there is one tiny minor problem that probably has a quick fix. Since the screens are being duplicated, both displays have a refresh rate of 60Hz as stated in the manuals. However on the computer monitor (not the TV) there is always some tearing occurring near the bottom of the screen, which is unusual considering both displays have the same refresh rate. It occurs in games and movies. Whenever I set to only show on the computer monitor it doesn't happen. Suggestions, anyone?

#19 aliali

aliali

    Titan

  • Super Hero
  • 23,567 posts

Posted 25 April 2012 - 11:39 PM

Well the normal fix for tearing is to turn on Vsync, although not sure this would help with a dual monitor setup, worth a shot though. For ATI it is in CCC > Gaming > 3d application settings >Wait for vertical refresh. Set to always on.
She's going to be really smart, very savvy, haunting good looks, really good at her job. And kind of slutty.

#20 tristan-117

tristan-117

    Learner

  • Quark
  • 54 posts

Posted 26 April 2012 - 05:03 PM

hmmm it was already on. Don't think it can be fixed.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users