Jump to content


Photo

Philips 288p - autosync 'flashing' on start up


  • Please log in to reply
3 replies to this topic

#1 shcveyc2

shcveyc2

    Serf

  • Lurker
  • 2 posts

Posted 25 March 2015 - 08:11 PM

Hi

 

I recently bought a Philips 288p.  There are known 'flickering' issues associated with the screen when it runs at 60 Hz - but this is not my problem.  I'm not a gamer so I haven't found this an issue.

 

The problem I have is when I start up the PC, or wakes up, the screen flashes, cycling through a variety of options as it tries to get the best screen resolution (3840 x 2160).  It takes two minutes roughly, then settles down and works fine.  But it is extremely annoying to have to wait several times a day for this activity.  I've gone to the Philips site and downloaded (and installed) the latest drivers, but to no avail.  It all worked fine when I initially installed the screen, I was able to select the different resolutions through the options on screen (bottom right) Digital DVI.  Now there is no choice.  It is something I can live with as I like the additional screen real estate over the 22" it replaced. 

 

Any suggestions and thanks in advance !



#2 Rybags

Rybags

    Immortal

  • Super Hero
  • 35,848 posts

Posted 25 March 2015 - 08:51 PM

That's kinda weird and would be real annoying.

It's nothing unusual at all for monitors to just go blank for 1/4 second when you have a resolution change or change of system sleep state but 2 minutes is utterly ridiculous.

 

If it's a common issue then no doubt it'd have been reported so it's probably worth a look to see if any knowledge base is maintained for the monitor or series.

 

Alternate to using system sleep and shutting off the monitor automatically you could just use a profile that powers off the HDDs after a couple of hours and use a screensaver instead of monitor powerdown.

Screensaver will do practically nothing to save power though and with LCDs they usually suck slightly less power to show an all-white screen vs an active all black one.



#3 codecreeper

codecreeper

    Champion

  • Atomican
  • 5,020 posts
  • Location:Adelaide, South Australia

Posted 26 March 2015 - 01:20 PM

try unplugging the DVI cable and see if it still happens ,use the menu system to change resolutions.

 

Is it a TV/Monitor setup or just a monitor?

 

You may also want to check the DVI cable it could have a bent pin.

 

It could be also that your Video card cannot support that higher resolution.

 

And its trying to set Video tables in your card for accessing ,can you check your memory and see if its gone down.

 

Another thing too if i remember 60hz was for USA TV's ,so try setting it back to 50hz.


Edited by codecreeper, 26 March 2015 - 01:23 PM.

Life is like a Straw , ...... it sucks.

 

 


#4 shcveyc2

shcveyc2

    Serf

  • Lurker
  • 2 posts

Posted 19 April 2015 - 08:34 PM

Ry, Code

 

I wanted to say thanks for your assistance and apologies for not getting back sooner with the outcome (I live in Sydney but work in Melbourne and didn't have time to get back to it until this week).  I tried your suggestions, without success.  So, I thought I either had an issue with a faulty screen (less likely) or the video card couldn't support the higher res (it was a Radeon HD6950) which was probably the issue.  I simply went and ordered a new video card (Palit GeForce GTX960) and installed it yesterday using the DisplayPort AND it worked perfectly.  No issues.  I'm very pleased as I had plugged in the 23" back in its place.






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users