Jump to content


Photo

DisplayPort Issues - GTX680FTW+ - 28" UE850 4k Display


  • Please log in to reply
3 replies to this topic

#1 Trigger_Troy

Trigger_Troy

    Serf

  • Lurker
  • 1 posts

Posted 30 December 2015 - 07:56 PM

Afternoon team,

 

I've been on atomic for many, many years.  I've lapsed over the last few years however and thought I'd come back fresh... with a problem of course.

 

Current System:

Windows 10
Z77 Sabertooth

EVGA GTX680 FTW+ 4Gig

16Gig Ram

Few years old, still holding up ok

 

 

What I know:

- GTX680 cards can output to 4k

- I can get 4k output via HDMI at 30hz - which is barely usable (3840x2160)

- Displayport should work perfectly, however is restricted to 2560x1440 at the moment - I should have access to 3840x2160

 

What I've tried:

- Monitor drivers

- nVidia drivers (clean installs, old versions etc)

- Motherboard BIOS Update
**EDIT I've also tried the OSD for the DP v 1.1 / 1.2 settings - this screen doesn't seem to be MTP and has 1.2 set by default
**Attempted to force it with CRU - no luck forcing  3840x2160 - CRU recognizes this as a resolution is should support

 

Question

 

I've seen a lot of people with these issues, however they seem to usually be rich dudes with 4 displays.. I am most definitely not one of them.  I wanted a display that would see me though another 10 years much like my BenQ 24" has done before this.

 

displayport.org says that all displayport cables are born equal and swapping this one out for another cable shouldn't have any impact.. however this will be the first thing i try.

 

*The monitor came with a mini display port to normal size cable, which I couldn't use.. i then proceeded to purchase a normal DP to DP from Msy in north melbourne.
*It was $6 (I think this may be the cause.. but according to displayport.org they would have me believe a cheapy may have issues, but this wouldn't be one of the issues)

 

Can anyone confirm that is could be the cable and is there any other troubleshooting I can perform?  I'm seriously stuck.. if i can't fix it tomorrow this monitor has to go back.. i can't drop $650 on a monitor that doesn't output at a res that should be supported no issues.

 

I have no idea how to look for logs or interogate the displayport on the graphics card for more info. 

 

BIOS is 80.04.28.00.80
Driver 10.18.13.6143 WHQL (ForceWare 361.43) / Win 10 64
Bus interface PCI-E 3.0 x 16 @ 16 3.0

GPU GK104

http://www.techpower...tx-680-ftw.html

 

 

Any info at all will be greatly appreciated

 

**Edit**

 

I've also tried the OSD for the DP v 1.1 / 1.2 settings - this screen doesn't seem to be MTP and has 1.2 set by default


Edited by Trigger_Troy, 30 December 2015 - 08:33 PM.


#2 Jeruselem

Jeruselem

    Guru

  • Atomican
  • 14,042 posts
  • Location:Not Trump-Land

Posted 31 December 2015 - 08:38 AM

Try a different cable, it's the cheapest way to see if the original cable is crap

Having trouble with A [?]OS11.1?

 

2018 FIFA World Cup Russia - Australia in but Italy, Chile, Netherlands, USA = FAIL.


#3 Rybags

Rybags

    Immortal

  • Super Hero
  • 35,060 posts

Posted 31 December 2015 - 10:12 AM

Check specs of both monitor and card for limitations e.g. what refresh rates for that resolution can be had, and whether running multiple monitors reduces what modes the cards can do.



#4 Dasa

Dasa

    Guru

  • Super Hero
  • 14,868 posts

Posted 04 January 2016 - 11:32 AM

looks a driver problem was a reason for this in the past maybe you have run into a similar problem

http://www.guru3d.co...eta_driver.html

 

best fix may be to trade in the old 680 to a gpu better suited to 4k


Silverstone TJ08-EW 6700k@4.7 1.375v - Z170-GENE - 2x8g 3866 16-16-16 - 1070@ 2100\9600MHz  -Samsung 830 64G, Sandisk Ultra II 960G, WD Green 3tb - Seasonic XP1050 - Dell U2713 - Pioneer Todoroki 5.1 Apogee Drive II - EK VGA-HF Supreme  - Phobia 200mm Rad - Silverstone AP181 Project Darkling
3770k vs 6700k RAM Scaling, HT vs RAM, Arma III CPU vs RAM, Thief CPU vs RAM
Parts Guide





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users