Jump to content


Photo

Arma 3 Crashing "STATUS_HEAP_CORRUPTION"


  • Please log in to reply
10 replies to this topic

#1 Tunnel_Rat

Tunnel_Rat

    Journeyman

  • Atomican
  • 241 posts

Posted 18 August 2017 - 08:31 PM

Hi guys

I am at a loss why Arma 3 keeps crashing it will crash in any game mode at any time. The exit code it comes up with is 0xC0000374 - STATUS_HEAP_CORRUPTION

I have had no luck finding answers online and the only problem I can find with my PC is the C: drive is almost full. But Arma 3 is loaded on its own SSD drive with plenty of room.

I have uninstalled the game and all its mods, reinstalled them and it did nothing still crashing.  I have saved a troubleshooting report for bohemia but am having problems uploading them on their website.

 

Anybody got any idea ? 

Could a STATUS_HEAP_CORRUPTION have anything to do with Ram ?

 

thanks for any help.

 

Will



#2 @~thehung

@~thehung

    Guru

  • Hero
  • 8,680 posts

Posted 18 August 2017 - 08:56 PM

try going into the Arma launcher and setting all options to default. 


no pung intended

#3 Tunnel_Rat

Tunnel_Rat

    Journeyman

  • Atomican
  • 241 posts

Posted 18 August 2017 - 10:32 PM

Thanks man  I did that and it did nothing so than I deleted the whole game and mods and reinstall it but same thing still crashes.

Its the only game I play its doing my head in.  Just put in a ticket with bohemia hope they can work something out.

 

thx



#4 Dasa

Dasa

    Guru

  • Super Hero
  • 14,879 posts

Posted 18 August 2017 - 11:05 PM

it may be on its own drive but it probably still uses the windows virtual memory which should be enabled on the c: drive despite some suggesting that you disable it with a ssd so just make sure its still enabled and windows managed

this guess is simply based on what you said about the error possibly being due to c: being full

 

is this the first time you installed arma or did something change after it had been working fine?

 

im enjoying playing arma3 antistasi coop at the moment so hope you get it sorted


Silverstone TJ08-EW 6700k@4.7 1.375v - Z170-GENE - 2x8g 3866 16-16-16 - 1070@ 2100\9600MHz  -Samsung 830 64G, Sandisk Ultra II 960G, WD Green 3tb - Seasonic XP1050 - Dell U2713 - Pioneer Todoroki 5.1 Apogee Drive II - EK VGA-HF Supreme  - Phobia 200mm Rad - Silverstone AP181 Project Darkling
3770k vs 6700k RAM Scaling, HT vs RAM, Arma III CPU vs RAM, Thief CPU vs RAM
Parts Guide


#5 Tunnel_Rat

Tunnel_Rat

    Journeyman

  • Atomican
  • 241 posts

Posted 19 August 2017 - 02:54 PM

Been playing arma for a few years and this just started about 4 weeks ago. Cannot think of anything that changed other than my C: drive becoming pretty full.

So today I replaced my HDD with a bigger one cloned a new SSD 250GB to replace the 120GB so now have plenty of room. Got on Arma3 was playing for over an hour thinking sweet its all good than bang crashed again same old 0xC0000374 - STATUS_HEAP_CORRUPTION

My virtual memory is enabled.

 

I have no idea what the next step is

 

thanks for your help



#6 Dasa

Dasa

    Guru

  • Super Hero
  • 14,879 posts

Posted 20 August 2017 - 06:30 PM

maybe run some stability tests on cpu\ram since arma is heavier on them than most other games

prime95 and the memory tests here work well for me http://www.overclock...tability-thread

 

try update drivers or if all current maybe try rollback windows to a month ago

fresh install of windows


Silverstone TJ08-EW 6700k@4.7 1.375v - Z170-GENE - 2x8g 3866 16-16-16 - 1070@ 2100\9600MHz  -Samsung 830 64G, Sandisk Ultra II 960G, WD Green 3tb - Seasonic XP1050 - Dell U2713 - Pioneer Todoroki 5.1 Apogee Drive II - EK VGA-HF Supreme  - Phobia 200mm Rad - Silverstone AP181 Project Darkling
3770k vs 6700k RAM Scaling, HT vs RAM, Arma III CPU vs RAM, Thief CPU vs RAM
Parts Guide


#7 Rybags

Rybags

    Immortal

  • Super Hero
  • 35,227 posts

Posted 20 August 2017 - 06:39 PM

A few hits with a search but by reinstall without mods it sounds like this hint won't be much help https://forums.bistu...ion-0xc0000374/


In your arma launcher revert all options to default. There have been a lot of improvements so none of the options are really needed anymore but there's a conflict from those.



#8 Master_Scythe

Master_Scythe

    Titan

  • Hero
  • 20,282 posts
  • Location:QLD

Posted 21 August 2017 - 09:00 AM

 

0xC0000374 - STATUS_HEAP_CORRUPTION

 

Honestly, run a Memtest boot disk over night. It's not uncommon to find one program that kills a system. It might just happen to stress that specific 100mb of RAM that's 'sometimes faulty' until it actually faults.

Other games or apps might not have the exact, (random numbers) 1.2GB of textures to load to make sure that the next 100mb (which in this theory is bad) is constantly used as the most active chip.

 

Goodluck.

 

Curiously, kept an eye on heat?


Wherever you go in life, watch out for Scythe, the tackling IT support guy.

"I don't care what race you are, not one f*cking bit, if you want to be seen as a good people, you go in there and you f*ck up the people who (unofficially) represent you in a negative light!"


#9 Tunnel_Rat

Tunnel_Rat

    Journeyman

  • Atomican
  • 241 posts

Posted 21 August 2017 - 05:46 PM

Thanks guys

I was thinking it could be a memory/ram problem but all the test I have run so far the ram shows up fine. I run the tests that Dasa linked (Thanks) and it came up fine. I will run the Memtest boot disk tonight.



#10 Dasa

Dasa

    Guru

  • Super Hero
  • 14,879 posts

Posted 21 August 2017 - 06:37 PM

memtest isnt likely to find much its all but useless these days unless there is serious instability

use to be great

 

which test did you run? multile instances of hci is good for memory controller issues and probably good enough for ram if run overnight while the linux test is excellent for ram and if it doesn't find anything you can rule out the ram as a problem


Edited by Dasa, 21 August 2017 - 06:38 PM.

Silverstone TJ08-EW 6700k@4.7 1.375v - Z170-GENE - 2x8g 3866 16-16-16 - 1070@ 2100\9600MHz  -Samsung 830 64G, Sandisk Ultra II 960G, WD Green 3tb - Seasonic XP1050 - Dell U2713 - Pioneer Todoroki 5.1 Apogee Drive II - EK VGA-HF Supreme  - Phobia 200mm Rad - Silverstone AP181 Project Darkling
3770k vs 6700k RAM Scaling, HT vs RAM, Arma III CPU vs RAM, Thief CPU vs RAM
Parts Guide


#11 Tunnel_Rat

Tunnel_Rat

    Journeyman

  • Atomican
  • 241 posts

Posted 11 September 2017 - 11:47 PM

Will I tried everything still just kept on crashing.

But I think its fixed now as it has not crash for days after the Arma 3 update. It would crash every game before so lets hope its fixed.

Thanks for all your help anyway guys always a great team on here.

 

thx

Rat






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users