Jump to content


Photo

Windows Doesn't Assign A Letter To USB Drives

drives windows plug and play

  • Please log in to reply
1 reply to this topic

#1 Camsie

Camsie

    Apprentice

  • Quark
  • 68 posts

Posted 22 September 2017 - 02:00 AM

My PC's developed an annoying little tic where it doesn't automatically assign a drive letter to USB drives (both HDD and flash) that I plug into it, forcing me to assign a letter manually via Computer Management. Problem doesn't seem to occur that much with drives that I plug in on a regular basis, but new drives and rarely-used drives don't get assigned a letter.

Once I've manually assigned a letter, though, the drives all behave normally.

Any idea how I can fix this?

Windows 7 64-bit.

Edited by Camsie, 22 September 2017 - 02:03 AM.


#2 Rybags

Rybags

    Immortal

  • Super Hero
  • 35,059 posts

Posted 22 September 2017 - 02:20 AM

Worth a try -

 

go into Command Prompt.  Type DISKPART.  It'll probably ask for admin permission (press Yes).

 

Type AUTOMOUNT ENABLE

Also, AUTOMOUNT SCRUB should supposedly remove any predefined definitions.  In theory you could use all the letters by manually assigning them to removable drives.

I'd just try the first one and see how it goes though.

 

EXIT to get out of Diskpart (or just close the window).







Also tagged with one or more of these keywords: drives, windows, plug and play

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users