Jump to content


Photo

[Guide]How to Fix Ubuntu 16.04 Desktop Restart After Shutdown

Ubuntu 16.04 shutdown problems

  • Please log in to reply
3 replies to this topic

#1 littlejacket92

littlejacket92

    Learner

  • Quark
  • 45 posts
  • Location:Trump Land

Posted 31 January 2018 - 03:04 PM

Recently I have meet this problem that when I shutdown my laptop, Ubuntu auto restart and cannot shut down. I tried some methods around internet, and I see many other people have troubles with this. Then I want to share with anyone here who have the same problem with their computer. I tracked this for somedays, and I know that it worked successful)

( If I made this topic wrong, please remove it, thanks)

 

If you use hp probook then, it may happen to your laptop when using Ubuntu. 

Please follow these  steps to fix it.

I did this step before: 

- Type in terminal
sudo nano /etc/default/grub
- then find a line
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
- Modify it to
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash" acpi=force apm=power_off

But it's not work because the next line they guide me is not found: 

Type in terminal sudo nano /etc/grub/modules then add apm power_off=1 under line lp. Save and close the terminal. 

Then I tried these two steps: And it worked. 

 

Step 2: sudo update-grub

Step 3: Turn off wifi, wired network

 

hope that help.


Edited by littlejacket92, 31 January 2018 - 03:06 PM.

Sleep all day here: https://savvycomsoftware.com/


#2 Rybags

Rybags

    Immortal

  • Super Hero
  • 35,678 posts

Posted 31 January 2018 - 03:16 PM

Shouldn't there be a filename as part of that path after the nano command?

Looks to me like some sort of config or auto exec type of thing, probably an option of the system and likely not included in minimalist installs.



#3 Master_Scythe

Master_Scythe

    Titan

  • Hero
  • 20,540 posts
  • Location:QLD

Posted 01 February 2018 - 01:17 PM

Thanks for that!

That will likely come in handy!

 

Being that I love some Ubuntu, and manage an ever aging fleet of Probooks :)


Shouldn't there be a filename as part of that path after the nano command?

Looks to me like some sort of config or auto exec type of thing, probably an option of the system and likely not included in minimalist installs.

 

Im not on my ubuntu machine to check, but as it's *nix, theres a good chance 'modules' is the file name.


Wherever you go in life, watch out for Scythe, the tackling IT support guy.

"I don't care what race you are, not one f*cking bit, if you want to be seen as a good people, you go in there and you f*ck up the people who (unofficially) represent you in a negative light!"


#4 SquallStrife

SquallStrife

    Really knows where his towel is

  • Atomican
  • 18,023 posts

Posted 02 February 2018 - 02:50 PM

Don't know how the solution in that AskUbuntu thread ever worked.

The source of that solution was a thread about a similar problem in 14.04.

My server is running 14.04 LTS. There is no /etc/group/modules. There is not even a /etc/grub directory.

root@atom:/etc# lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description:    Ubuntu 14.04.5 LTS
Release:        14.04
Codename:       trusty
root@atom:/etc# cd /etc/grub/modules
-bash: cd: /etc/grub/modules: No such file or directory
root@atom:/etc# cd /etc/grub
-bash: cd: /etc/grub: No such file or directory
Sometimes the Internet is a great source of solutions. Most of the time it's shit though.
SyDjDDk.png [retro swim] | AzpUvwG.png @retroswimau | q5O6HgO.png +RetroSwim
四時半を待っています!




1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users