Welcome Guest ( Log In | Register )

 
Reply to this topicStart new topic
Fixing key bindings in Dead Space 1, Screw you EA thread #386
Bastard Child
post Jun 26 2011, 12:58 PM
Post #1
Atomican
Primarch




After years of having this game sit on the shelf unplayed, due to poor keyboard controls for us lefties and just piss-poor mouse, I'm finally bored enough to do something about it!


How to edit Dead Space 1 key bindings:

You can either do the GlovePIE method here or manually edit the key bindings. I haven't found a way to change any of the red 'locked' keys, so it might not be possible.

1. Start the game and go into the options -> controls screen and change any one keyboard key (hit the accept key) so that a file called "controls.rmp" is created. Quit the game.

On my Win7 machine the default path is: C:\Users\*computer name*\AppData\Local\Electronic Arts\Dead Space\controls.rmp

You may have to enable hidden files and folders.

2. Download and install XVI32 hex editor - link here from this website here

3. Run the application and load the 'controls.rmp' file. You screen will look like this:


Drag the corner of the window to resize it. You want the data looking like this:


Each keyboard key (and alternate key) is stored in these two columns:
<- note that each key has a unique address where it can be found

You'll find this screen is used to manually enter your own key:


So how do we know what address does what?

4. This google doc here lists:
Control Action -> the default keyboard key -> what hex value this is -> where the hex value is found (hex address) -> alternate key, etc.

And how do we know what hex value represents each key on a keyboard?

5. Scroll down to section 8.13 here? or the section called Keyboard Scan Code found here (column set 1)

6. After making your changes to controls.rmp, save it, and load the game

7. If something screws up, you can reset your keys back to default in the game's option screen

I haven't found a way to change the red keys, so bad luck.


To make the mouse work better ("that's how the devs want you to play it" is just excusing poor programming):

-Disable in-game VSync
-Force Vsync through control panel
-Force Triple Buffering (Direct 3D) through control panel (third party app. for ATI owners)

Edit "settings.txt" found in the same folder as the previous file and scroll down to "Control.MouseSensitivity". I've made it 1.5 (I think it goes to 4):


Note that menu controls will become overly sensitive.


Bam.

This post has been edited by Bastard Child: Jun 26 2011, 12:59 PM
Go to the top of the page
 
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



Lo-Fi Version Time is now: 24th July 2014 - 08:09 AM