Welcome Guest ( Log In | Register )

 
Reply to this topicStart new topic
Audio stops working through HDMI.
leonhart83
post Nov 13 2011, 08:53 AM
Post #1
Atomican
Master




Hey guys,

Here are my computer specs

i5 760
evga p55 ftw
corsair 450W
8gb of corsair ram
ati 4890

Just recently I purchased a cheap Vivo 40" Tv from DSE for my xbox and PC gaming. I had issues originally with this setup through the HDMI where the montior would keep dropping out as if losing signal and regaining signal. I used a different HDMI cable which seemed to fix this issue. Now with the new cable I am sometimes coming back to my PC and noticing that the sound through the HDMI/4890 says it is unplugged. The video is still going through the HDMI as I can see but the sound will not working until I unplugged and re-plug in. Even after disabling and renabling in playback devices.

Any ideas on how to fix this?

EDIT: I haven't noticed it EVER dropping out when I am actually using the PC, only when I come back from not using it for a while (I don't turn this computer off)>

Thanks,

Micky.

This post has been edited by leonhart83: Nov 13 2011, 08:55 AM
Go to the top of the page
 
+Quote Post
Bala_Matt
post Nov 13 2011, 09:07 AM
Post #2
Atomican
Journeyman




Is TV switched off in between use?
Is computer going in to any low power mode?

I have similar issue. Now is fixed by following this procedure. Ensure TV is fully awake/on prior to waking computer from sleep/hibernate/screen saver.

Essentially if computer "wakes" or whatever, and doesn't "find" the screen already fully on it doesn't activate audio signal even though it eventually activates the video signal.

This post has been edited by Bala_Matt: Nov 13 2011, 09:08 AM


--------------------
i5 2500k, Antec Kuhler H2O 620, Gigabyte Z68, G.Skill 8gb Ripjaws, Gigabyte GTX 570 OC, Coolermaster Ammo 533 Case, OCZ ModXtreme 650 watt, WD HDs, LG Bluray/DVD combo, Steel Series Cans, MS Ergo KB, Witcher2 laser mouse I won from PC PowerPlay :)
Go to the top of the page
 
+Quote Post
Periander
post Nov 13 2011, 09:31 AM
Post #3
Atomican
Overlord




I have the same problem with my receiver which takes audio and visual from the PC and outputs visuals to the TV and audio to the speakers. For me, turning the receiver off and on again fixes it.

Maybe try turning the TV off and on, or change channels and back to that HDMI source.

This post has been edited by Periander: Nov 13 2011, 09:32 AM
Go to the top of the page
 
+Quote Post
Boosta
post Nov 13 2011, 01:03 PM
Post #4
Atomican
Master




Yeah same issue for me on a 4850. Only does it when coming out of sleep if I have the receiver turned off. I usually give it a minute then I right click on the little speaker icon on the taskbar and re-enable the hdmi out on the video card as the default playback device and it fixes it. That is on Windows 7 btw.

This post has been edited by Boosta: Nov 13 2011, 01:03 PM


--------------------
Q9550 @ 3.8GHz (450x8.5) 1.28v | TR Silver Arrow | X48-DS4 | 4GB OCZ Platinum 1066MHz DDR2 | 2x HD4870 in CF | Corsair HX-620 | WD 640GB SATAII | Raven Case | Windows 7
Go to the top of the page
 
+Quote Post
leonhart83
post Nov 14 2011, 10:36 AM
Post #5
Atomican
Master




QUOTE (Boosta @ Nov 13 2011, 01:03 PM) *
Yeah same issue for me on a 4850. Only does it when coming out of sleep if I have the receiver turned off. I usually give it a minute then I right click on the little speaker icon on the taskbar and re-enable the hdmi out on the video card as the default playback device and it fixes it. That is on Windows 7 btw.



Yeah I haven't had any luck with the above posters ideas. It still doesn't seem to want to work. I will try yours this afternoon. I have bought a HDMI switch so that I can switch between the TV and my computer monitor so in the worst case scenario that your idea doesn't work I will have a workaround.

TBH I don't feel very confident, as it is coming up as unplugged in the playback menu. Maybe when changing it to default it attempts to bring it up again. Who knows.
Go to the top of the page
 
+Quote Post
leonhart83
post Nov 14 2011, 12:05 PM
Post #6
Atomican
Master




QUOTE (leonhart83 @ Nov 14 2011, 10:36 AM) *
QUOTE (Boosta @ Nov 13 2011, 01:03 PM) *
Yeah same issue for me on a 4850. Only does it when coming out of sleep if I have the receiver turned off. I usually give it a minute then I right click on the little speaker icon on the taskbar and re-enable the hdmi out on the video card as the default playback device and it fixes it. That is on Windows 7 btw.



Yeah I haven't had any luck with the above posters ideas. It still doesn't seem to want to work. I will try yours this afternoon. I have bought a HDMI switch so that I can switch between the TV and my computer monitor so in the worst case scenario that your idea doesn't work I will have a workaround.

TBH I don't feel very confident, as it is coming up as unplugged in the playback menu. Maybe when changing it to default it attempts to bring it up again. Who knows.


Yeah the option for making it the default is greyed out because it has detected it as being unplugged.
Go to the top of the page
 
+Quote Post
Dasa
post Nov 14 2011, 08:53 PM
Post #7
Super Hero
Guru




i have noticed when my screen goes to sleep but pc is still on sound stops playing coming from the gtx480 hdmi but i havent had any troubles with it resuming as yet
just mentioning incase your monitor is set to go to sleep and its something to do with that


--------------------
2600k@4.8GHz 1.38v - Z77-GENE - 2x4g 1600 8-9-8 - 7970 1150\7000MHz 1.15v - OCZ Synapse 120g Seagate 2tb - Seasonic XP1000 - Dell U2711 - Pioneer Todoroki 5.1
Storm G5 - MCW60 - EK-VGA HF - MCP355 XSPC Restop - PA120.4 - Scythe GT 4x120 1440/1850rpm http://i3.photobucket.com/albums/y83/dasa09/z77rog.jpg
Go to the top of the page
 
+Quote Post
leonhart83
post Nov 16 2011, 12:27 PM
Post #8
Atomican
Master




QUOTE (Dasa @ Nov 14 2011, 08:53 PM) *
i have noticed when my screen goes to sleep but pc is still on sound stops playing coming from the gtx480 hdmi but i havent had any troubles with it resuming as yet
just mentioning incase your monitor is set to go to sleep and its something to do with that



As I stated in the first post, I originally had a display issue that was fixed by changing HDMI cables to a new one. I did a test that I ran throughout the day where I used the original cable (the one with the shitty display) and it did not drop the audio. So I have put and order for a new 1.4 HDMI cable that I think will fix the issue. I am currently it in a workaround configuration until I can test this more. It looks like it might just be two dodgy ebay cables that is the culprit.

Thanks,

Micky.
Go to the top of the page
 
+Quote Post
Periander
post Nov 17 2011, 04:51 AM
Post #9
Atomican
Overlord




You did suggest that it was only happening when you were away from your PC; maybe disable all of the sleep options in the power configuration for a few days and see if it goes away then too.
Go to the top of the page
 
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



Lo-Fi Version Time is now: 26th July 2014 - 05:43 AM