Jump to content
Sign in to follow this  
mark84

X-Fi mature enough under 64-bit Vista?

Recommended Posts

Just wondering if Creatives X-Fi cards now work ok under 64-bit Vista? Specifically are the driver/programs now mature enough? Game support ok? Do you have to do anything with the whole Alchemy thing to get Valve Source type games running, or CoD4, RA3 or other more recent games running?

 

When I was doing the purchasing for my PC upgrade it was in the period where Creative were under a lot of flak for their lack of driver support etc. So I bought an Asus Xonar D2X as I knew it was going to work under Vista 64bit.

 

But the driver/program features just seem lacking compared to my previously owned Audigy 2 ZS and miss some of the more fancier driver/program features that it had compared to my current Xonar. Specifically having stereo auto 'up mixed' (I think it's called) to 5.1. ATM with the Xonar I have to go into the driver and switch it to 2 speaker mode and let my speakers do the up mixing. Have to stop music/video etc, go into drivers switch it, then start playback again, then remember to switch it back to 6 speaker mode afterwards. Switching whilst audio is playing crashes whatever is playing.

 

The other thing is that the Xonar doesn't like being put into hibernation/sleep. If I put my PC into sleep mode or hibernate the card powers off but the drivers don't realise the card was powered off and doesn't turn the card back on when returning to Windows (you hear a click when the card turns itself on/off). So that's another reason I'm looking at getting an X-Fi.

 

I'm no audio enthusiast, I just like having nice features/abilities I can play with, so I was looking at maybe getting an X-Fi Titanium (seems to be the same as the Titanium FATAL1TY Pro just with out the shroud and as much 'x-ram' but ~$90 less), but just want to make sure it'll actually work stably and do what my current card does before doing anything.

 

Any comments or thoughts would be appreciated :)

Share this post


Link to post
Share on other sites

Got a friend running 64-bit Vista Ultimate... he bought an X-Fi Platinum... couldn't get it going at first, but he just played around and eventually got the correct driver and now it works fine.

Share this post


Link to post
Share on other sites

I have an X-FI Extream Music card and and I am running vista 64bit. Initially there were major problems with the drivers but its all fixed now. Just download the latestest drivers from the Creative site and the Alchamy update as well and you should be fine. I have heard good things about Auzentech and HT Omega as well if that helps.

 

Cheers

Share this post


Link to post
Share on other sites

I'm running 64 bit vista ultimate and creative xfi xtreme audio and it's fine. No troubles with it at all. Ran the install from the cd and it worked first go.

Edited by spaced

Share this post


Link to post
Share on other sites

Thanks for the replies, looks like I'll get me one with the money get from Uncle Rudd ;)

Share this post


Link to post
Share on other sites

Thanks for the replies, looks like I'll get me one with the money get from Uncle Rudd ;)

You mean the cranky vego, don't you?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×