Jump to content
Sign in to follow this  
Vanne

What games are W7 compatible?

Recommended Posts

Hi, just wondering what games are compatible. Iam about to install W7 and dont wanna be stuck without my games.

 

will anything that runs on Vista run on W7?

 

cheers

 

oh, iam running a raid 0 ich10r setup, will W7 find the array no dramas?

Share this post


Link to post
Share on other sites

Technically everything that works on Vista should run on Windows 7. As for the RAID, I'm unsure. It should be fine though.

 

Oh, and it's still in Beta/RC, so you shouldn't have it as your main OS anyhow. Make a new partition for it.

Edited by .:Cyb3rGlitch:.

Share this post


Link to post
Share on other sites

er....V8 Supercars 3 won't install properly......there's one!

What's the error?

 

Every error I've come across installing games in W7 is because of poorly coded version checks.

Share this post


Link to post
Share on other sites

Ohkay, ive installed Windows 7, and updated my vid driver, but uhrmm... what about mobo drivers? dont you have to install anything else? i tried to install my MSI chipset driver, (downloaded the X86 vista 32 bit version) from the MSI webby, but it says when i go to install it, that the OS isnt supported?

 

Seems to run fine though, does it have generic drivers for P45 chipsets?

 

cheers

Share this post


Link to post
Share on other sites

er....V8 Supercars 3 won't install properly......there's one!

What's the error?

 

Every error I've come across installing games in W7 is because of poorly coded version checks.

 

 

it goes thru the motions of installing, but never appears in the menu, and when you put the disc in wants to install again. it appears in windows explorer, but not all the files necessary are there. that was with Windows 7 7068 x64 bit -I'm running 7106 x32 atm, I'll try it again - I'm in XPx64 atm, but I'll give it another go later on if you like.

Share this post


Link to post
Share on other sites

okay, well I installed V8 Supercars 3 (using Windows 7 x32 build 7106) and it's an improvement over earlier builds, it actually installs the program, but, upon rebooting, an error message about a 'Starforce Protection driver comes up briefly, then, when I attempt to start the game, it asks to reboot the system (which is normal), which I do, then, start the game again, same message about rebooting, so I hit it with the 1.1 patch, reboot, start the game same reboot BS ad infinitum......

I'll load the latest x64 bit version (7100) later on and give it a whirl, see if x32 or x64 makes a difference

Share this post


Link to post
Share on other sites

okay, well I installed V8 Supercars 3 (using Windows 7 x32 build 7106) and it's an improvement over earlier builds, it actually installs the program, but, upon rebooting, an error message about a 'Starforce Protection driver comes up briefly, then, when I attempt to start the game, it asks to reboot the system (which is normal), which I do, then, start the game again, same message about rebooting, so I hit it with the 1.1 patch, reboot, start the game same reboot BS ad infinitum......

I'll load the latest x64 bit version (7100) later on and give it a whirl, see if x32 or x64 makes a difference

Get a crack and disable starforce in device manager. Thats what I did in flatout 2 on vista 64 (no 64bit starforce driver at the time)

Share this post


Link to post
Share on other sites

okay, well I installed V8 Supercars 3 (using Windows 7 x32 build 7106) and it's an improvement over earlier builds, it actually installs the program, but, upon rebooting, an error message about a 'Starforce Protection driver comes up briefly, then, when I attempt to start the game, it asks to reboot the system (which is normal), which I do, then, start the game again, same message about rebooting, so I hit it with the 1.1 patch, reboot, start the game same reboot BS ad infinitum......

I'll load the latest x64 bit version (7100) later on and give it a whirl, see if x32 or x64 makes a difference

Get a crack and disable starforce in device manager. Thats what I did in flatout 2 on vista 64 (no 64bit starforce driver at the time)

 

 

so, it's the Starforce Driver that's causing it to want to reboot?

Share this post


Link to post
Share on other sites

so, it's the Starforce Driver that's causing it to want to reboot?

Starforce has all sorts of problems, even in XP x86...

 

Crack it, the game itself will probably work fine.

Share this post


Link to post
Share on other sites

damm starforce, if i dint have a damm external sony dual layer burner, i would have never been able to play Bioshock. Pioneer drives hate starforce.

Share this post


Link to post
Share on other sites

i have some dramas playing games due to nvidia drivers. however, it is an older card, so thats just as likely the real cause of the problem.

 

i've not been in the mood to game on the pc lately, so i've not really sought out ways to remedy this issue.

Share this post


Link to post
Share on other sites

I'm running the 64bit windows 7 RC, and there's 2gigs 667 ram.

 

Stalker modded to 'The Priboi Story' works fine, I still get ctd's, but that's a given with Stalker.

 

When running or walking in game, I can do a quick save, and it hardly affects the game play at all.

There's just a blink in the movement, and it's saved.

 

Also in the bar, where the radio is playing, I can take a screen shot, and there's almost no discernible break in the audio stream when doing so.

<The first time I took a screenie I saved and exited to check if it 'DID' take the shot, and it had.>

It's that quick O_O

 

Under XPP and XPH both of the above stopped game play for a while.

-------------------

 

So it appears that freeing up more ram for the user is really making a difference .

:-)

Share this post


Link to post
Share on other sites

Win7 x64

 

StarCraft + Brood

AoE + RoR

AoE 2 + The Conquerors

Jedi Academy

The Witcher

 

NWN2 DVD still doesn't work. (frakked securom or whatever theyre using).

Share this post


Link to post
Share on other sites

I copied my Guild Wars folder over from XPH and had a few probs trying to get the GW.exe to run.

But when I chose to run it in 'XP (SP3) compatability mode, it ran first time.

 

No probs so far, and it's been about 20 mins since start time.

 

Quite happy now....

Thank you.

:)

Edited by pekkahead

Share this post


Link to post
Share on other sites

So far so good. :) the witcher is kicking butt. :)

W7RC1 -> Eve online, Age of Conan and Supreme Commander work fine.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×