Jump to content

Notebook Network Adapter not working

Recommended Posts

Hey guys,


I'm having a problem with my Asus Notebook Network Adapter. A week ago i went to plug a cat5 cable into the adapter/enable the device and i noticed the 'connection' had disappeared.


I went into the Device Manager to see what the problem was and i saw the ! infront of the device.


double clicked to go into the properties and this is what it had displayed.


This device cannot start. (Code 10)


Click 'Check for solutions' to send data about this device to Microsoft and to see if there is a solution available. - clicking that doesnt do anything.


Location: PCI bus 0, device 10, function 0


I uninstalled the network adapater, reinstalled the original drivers... no change.. went through the same process only with the latest drivers.... same problem again.


I've contacted Asus about it, the only thing they told me told me to do is 'book it in for repair' I have warranty for this Notebook but i'd rather not send it away if i dont have to.


If someone can help me out with this dilema i'd appreciate it, this laptop is only 5 weeks old :(


OS - Vista home premium

Notebook - Asus X61G Series

Network card - NVIDIA nForce




Share this post

Link to post
Share on other sites

Sounds like a faulty adapter to me, as you say you reinstalled the drivers and had no joy. One word of advice before you return it for repairs, make sure you back up any files you want to keep. As formatting a computer before returning it to the owner is usually standard procedure.

Share this post

Link to post
Share on other sites

If you plug in the cat5 cable after turning on the notebook, before windows loads, does it have lights, i.e. is it sending data?


Did you change anything before this started happening? Any updates etc?

Share this post

Link to post
Share on other sites

This is where a linux/BSD live CD comes in handy.


It's always good to be able to confirm whether the same problem is present under another OS so you can determine whtehr it's hardware or software.


Also, I vaguely remember reading something about Acer Aspire laptops having some really oddball problem wither ethernet, that could only be fixed by unplugging them from the wall and doing some other seemingly improbable things.


I think elvenwhore posted something on this once, and with luck she'll pipe up in here, because I realise my vague memory isn't that helpful.


(and it probably isn't the problem, anyway.)

Share this post

Link to post
Share on other sites

I've seen this happen with onboard Ethernet adapters quite a bit on desktop systems. Here's the workaround I've used*:


1) Disable and re-enable the network adapter in Device Manager.


Sounds like you've already tried this one?


2) Uninstall and reinstall the drivers.


From what I gather, you've tried this already too?

3) TCP/IP and Winsock repair.


There are 2 ways to do this:


Go to a command prompt and type:


netsh int ip reset c:/resetlog.txt

then press <Enter>. When the cursor comes up on a new line, type


netsh winsock reset catalog

then press <Enter>


You should see:


Successfully reset the Winsock Catalog. You must restart the machine in order to complete the reset.

Reboot and you're done.


Alternatively, use Winsockfix.exe or a similar application to do it for you :)


4) Install another network adapter.


I realise this might not appear to be an option with a laptop, however even installing a USB-to-Ethernet adaptor or USB driver for an ADSL modem is sometimes enough to repair corrupted system files that the TCP/IP and Winsock fix won't get.


*Your results may vary. Pray to the gods of TCP/IP and device drivers if problems persist.

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now