Jump to content
cleadge

*sigh* remote desktop is broken

Recommended Posts

I couldn't find any topics relating to this.

So, after a quick google late last night and today. I have been unable to workaround/repair my issue.

 

Im trying to connect to another PC in the house (XP machine) from my PC (Vista), now whenever i attempt to connect to the XP machine with RDC it stops responding and gives this error.

Also both machines are fully patched and up-to-date, i have tried with no firewall enabled (PC or router), i have also checked that all the correct services are enabled.

 

RDC error

Problem signature:
  Problem Event Name:	APPCRASH
  Application Name:	mstsc.exe
  Application Version:	6.0.6002.18005
  Application Timestamp:	49e02f4f
  Fault Module Name:	mstscax.dll
  Fault Module Version:	6.0.6002.18005
  Fault Module Timestamp:	49e0417c
  Exception Code:	c0000005
  Exception Offset:	00000000001a1314
  OS Version:	6.0.6002.2.2.0.256.1
  Locale ID:	3081
  Additional Information 1:	681c
  Additional Information 2:	74284c9304316c0f8d346a1126f9f945
  Additional Information 3:	6482
  Additional Information 4:	00e96729f0d4bcd3197358602dca239c

NXclient error

Problem signature:
  Problem Event Name:	APPCRASH
  Application Name:	NXWin.exe
  Application Version:	0.0.0.0
  Application Timestamp:	496b2791
  Fault Module Name:	ntdll.dll
  Fault Module Version:	6.0.6002.18005
  Fault Module Timestamp:	49e03824
  Exception Code:	c0000710
  Exception Offset:	0006a70c
  OS Version:	6.0.6002.2.2.0.256.1
  Locale ID:	3081
  Additional Information 1:	e867
  Additional Information 2:	9fff203f674dffac547d9eb029972c1c
  Additional Information 3:	5c89
  Additional Information 4:	89787c9d9a23811755f1a6c01752563b

and DameWare Mini RC error

Problem signature:
  Problem Event Name:	APPCRASH
  Application Name:	DWRCC.exe
  Application Version:	6.8.1.4
  Application Timestamp:	498a09ca
  Fault Module Name:	mstscax.dll
  Fault Module Version:	6.0.6002.18005
  Fault Module Timestamp:	49e0378f
  Exception Code:	c0000005
  Exception Offset:	0015b81d
  OS Version:	6.0.6002.2.2.0.256.1
  Locale ID:	3081
  Additional Information 1:	fd00
  Additional Information 2:	ea6f5fe8924aaa756324d57f87834160
  Additional Information 3:	fd00
  Additional Information 4:	ea6f5fe8924aaa756324d57f87834160

Im thinking that mstscax.dll is corrupted or something, as it rears its head twice with two different apps.

Would be great to resolve this, but if not its no big loss.

Edited by cleadge

Share this post


Link to post
Share on other sites

It crashes when connecting from Vista to XP..what about from XP to Vista?

 

When was the last time it was working? Try rolling back the system to before the latest updates were installed, and see if that works.

Share this post


Link to post
Share on other sites

Im not sure if it worked before yesterday or before i last updated, as i only tried it last night.

Yea its XP pro

I have not tried from XP to vista yet, will go do that now.

 

Edit: XP to Vista doesn't work, the XP comp isnt able to see Vista shared docs or the PC at all even tho its all correctly configured (visible to friends PCs when they are over).

Edited by cleadge

Share this post


Link to post
Share on other sites

IIRC only some versions of Vista (Business & Ultimate?) can be rdp'd to.

Share this post


Link to post
Share on other sites

So, you are able to connect and authenticate, and after an indeterminate amount of time, the connection drops out resulting in the crash?

 

Or does it crash instantly upon connecting?

 

Also, if you have SP3 applied to the XP machine, check the event log for an error regarding the RDP protocol.

Edited by TheSecret

Share this post


Link to post
Share on other sites

Reads to me that it's crashing on connect, hasn't connected or authenticated yet.

Share this post


Link to post
Share on other sites

Well, he said it stops responding, which indicates that it may connect and then crash.

Edited by TheSecret

Share this post


Link to post
Share on other sites

it crash's as soon as i attempt to connect.

i can ping both ways from xp>vista and vista>xp

Share this post


Link to post
Share on other sites

This doesnt help you solve the problem, but in the mean time install TightVNC on both machines and you can still do what you're trying to do. Just a stopgap till you sort it out.

Share this post


Link to post
Share on other sites

Yea i think ill go with TightVNC. o well, thanks for the ideas guys. if/when i get a solution ill post it here.

Share this post


Link to post
Share on other sites

If you wanted to solve the problem, you could have tried providing answers to the people seeking clarification so they could help you.

Share this post


Link to post
Share on other sites

If you wanted to solve the problem, you could have tried providing answers to the people seeking clarification so they could help you.

Nah mate..that goes against the 'Atomic Way'

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×