Jump to content
Sign in to follow this  
just_some_guy

Windows Networking SNAFU

Recommended Posts

I have two PCs, one running XP, the other running Vista.

 

Both belong to the same workgroup.

 

I have shared a folder on the Vista PC. (Advanced sharing, gave it a unique name, gave full read/write permission to everyone.)

 

When I open the workgroup, via Network Places, on the XP PC, the shared folder on the Vista PC shows up, as it should.

 

But when I try to open the Vista PC's shared folder, I am told it is 'not accessible'. And that I 'might not have permission to use this network resource'. And 'Access is Denied'.

 

What am I doing wrong? I have given full access to this folder to everyone! I can see the damned folder in the workgroup, but I can't open it. I have tried changing its name, chaning its permission levels, turning off all firewalls, but I still can't open it.

 

Incidentally, a different shared folder on the Vista PC is full accessible, as it should be.

 

Suggestions would be appreciated, thanks.

Share this post


Link to post
Share on other sites

I have shared a folder on the Vista PC. (Advanced sharing, gave it a unique name, gave full read/write permission to everyone.)

Was that share permissions or filesystem permissions?

 

A user can have the "Full Access" permission on the actual share, but not have filesystem-level access to the folder being shared...

Share this post


Link to post
Share on other sites

Everyone does not equal anyone.

 

Everyone who has a username on the Vista computer and logs in as such will have access but if you have a user called fred on the XP machine and no user called Fred on the Vista machine (with matching password) then it won't work. If you aren't getting prompted for a username and password then it is trying to pass-through it's XP credentials.

Share this post


Link to post
Share on other sites

I've gone Folder Properties -> Sharing Tab -> Advanced Sharing -> Share this folder -> Permissions ->Share Permissions -> Everyone -> Full Control

 

What have I missed?

 

(Reading those links above now, thanks.)

Edited by just_some_guy

Share this post


Link to post
Share on other sites

Check out the "Security" tab on the folder properties.

 

Edit: I'm at work at the mo, I can confirm the name of the tab once I get remoted in.

Edited by SquallStrife

Share this post


Link to post
Share on other sites

Hurrah!

 

The network type had to be changed (and then the whole system rebooted) but now it works!

 

Thank you thank you thank you!

Share this post


Link to post
Share on other sites

Interesting that that was the cause, given you could access that other folder... O.o

 

Anyhoo, glad you got it running.

 

For future reference, the permissions under the "Sharing" tab only affect the share object. Check out the "Security" tab for the filesystem-level permissions. :)

Share this post


Link to post
Share on other sites

Hurrah!

 

The network type had to be changed (and then the whole system rebooted) but now it works!

 

Thank you thank you thank you!

Glad that helped. Caused me some headaches a while ago too.

Share this post


Link to post
Share on other sites

Interesting that that was the cause, given you could access that other folder... O.o

Yeah, totally odd. Thanks again, guys, really appreciate your help.

Share this post


Link to post
Share on other sites

Interesting that that was the cause, given you could access that other folder... O.o

Yeah, totally odd. Thanks again, guys, really appreciate your help.

 

Not totally odd at all if you read the associated "help me choose" with choosing which network type to use.

Home or Work

Choose one of these locations for home or small office networks when you know and trust the people and devices on the network. Network discovery, which allows you to see other computers and devices on a network and allows other network users to see your computer, is on by default. For more information, see What is network discovery?

 

Public place

Choose this location for networks in public places (such as coffee shops or airports). This location is designed to keep your computer from being visible to other computers around you and to help protect your computer from any malicious software from the Internet. Network discovery is turned off for this location.

Note

If there’s only one computer on your network and you know you won’t need to share files or printers, the safest choice is “Public place.”

Edited by aliali

Share this post


Link to post
Share on other sites

Not totally odd at all if you read the associated "help me choose" with choosing which network type to use.

But that doesn't quite explain why one folder was able to be accessed, but not another.

 

It explains why public/private is a good/bad idea, but not how the situation seemed to be halfway between...

Share this post


Link to post
Share on other sites

The way security works with windows filesharing i guess the best way would be to say it works in layers. First thing hit is the share permission where if the person logging into the computer does have the correct credentials then they are kicked out strait away, then after that you have ntfs filesystem permissions. Active directory has always been designed so that permissions on the local machine and the share have to be consistent so yeah if you don't have anything on one, then then you'll only get so far..

 

Anyway hope that helps with explaining it.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×