Jump to content
njbignell

Trouble Configuring SFP Module for CISCO Switch

Recommended Posts

I've just bought a Catalyst 2960 Series 24-port switch with SFP module but whenever I plug the fibre into the module I simply get no connection at all. I called CISCO and they sent me an IOS command to change the media type to SFP but that hasn't helped. I was thinking enabling auto negotiation would help but I can seem to get it working.

 

Here's some output from the IOS:

 

SWT04#show interface g0/1

GigabitEthernet0/1 is down, line protocol is down (notconnect)

Hardware is Gigabit Ethernet, address is 081f.f36c.2599

MTU 1500 bytes, BW 10000 Kbit, DLY 1000 usec,

reliability 255/255, txload 1/255, rxload 1/255

Encapsulation ARPA, loopback not set

Keepalive not set

Full-duplex, 1000Mb/s, link type is auto, media type is 1000BaseSX SFP

input flow-control is off, output flow-control is unsupported

ARP type: ARPA, ARP Timeout 04:00:00

Last input never, output never, output hang never

Last clearing of "show interface" counters never

Input queue: 0/75/0/0 (size/max/drops/flushes); Total outpt drops: 0

Queueing strategy: fifo

Output queue: 0/40 (size/max)

5 minute input rate 0 bits/sec, 0 packets/sec

5 minute output rate 0 bits/sec, 0 packets/sec

0 packets input, 0 bytes, 0 no buffer

Received 0 broadcasts (0 multicasts)

0 runts, 0 giants, 0 throttles

0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored

0 watchdog, 0 multicast, 0 pause input

0 input packets with dribble condition detected

0 packets output, 0 bytes, 0 underruns

0 output errors, 0 collisions, 1 interface resets

0 babbles, 0 late collision, 0 deferred

0 lost carrier, 0 no carrier, 0 PAUSE output

0 output buffer failures, 0 output buffers swapped out

 

Thanks to anyone that can help, cheers

Share this post


Link to post
Share on other sites

Can you give us a sh run?

TRCSWI04#sh run

Building configuration...

 

Current configuration : 3106 bytes

!

version 12.2

no service pad

service timestamps debug datetime msec

service timestamps log datetime msec

##########################

!

hostname TRCSWI04

!

boot-start-marker

boot-end-marker

!

enable secret 5 ################################################

!

no aaa new-model

system mtu routing 1500

ip subnet-zero

!

!

!

crypto pki trustpoint TP-self-signed-4083950976

enrollment selfsigned

subject-name cn=IOS-Self-Signed-Certificate-4083950976

revocation-check none

rsakeypair TP-self-signed-4083950976

!

!

crypto pki certificate chain TP-self-signed-4083950976

certificate self-signed 01

30820241 308201AA A0030201 02020101 300D0609 2A864886 F70D0101 04050030

31312F30 2D060355 04031326 494F532D 53656C66 2D536967 6E65642D 43657274

69666963 6174652D 34303833 39353039 3736301E 170D3933 30333031 30303030

34395A17 0D323030 31303130 30303030 305A3031 312F302D 06035504 03132649

4F532D53 656C662D 5369676E 65642D43 65727469 66696361 74652D34 30383339

35303937 3630819F 300D0609 2A864886 F70D0101 01050003 818D0030 81890281

8100A46C B0E7479B 22822F94 CB74798F 1BA1399F 182DF9CF 23668397 2D383D89

B8F2B3C8 CF363C41 E0F00F51 B15FE784 F07BD9AA 63283708 979A82C0 9D6DBA77

91EB386E D81FDAB2 78FDA00F 3EA814D4 0D6AC2DB 5B29C857 DBA3A045 343938A7

7CE94078 9CDCBF7F 9046EF45 0E5B3DD8 BE684FDE A8D65000 AEBD0C54 DB462061

B7D70203 010001A3 69306730 0F060355 1D130101 FF040530 030101FF 30140603

551D1104 0D300B82 09545243 53574930 342E301F 0603551D 23041830 16801467

3697572D D5D36116 66612B03 D769782B FC1EFE30 1D060355 1D0E0416 04146736

97572DD5 D3611666 612B03D7 69782BFC 1EFE300D 06092A86 4886F70D 01010405

00038181 005D02DA 4FAF3E47 BA4803BC 55DC6DE3 7F344319 DD6D20FB A9B3EEDF

BDC55A2E 0FE69955 B586C254 206B2546 E64CBD68 26640818 0DA69FD8 428A5D00

53AC94B3 6C7E910E 8B74D0BE 746A5AD9 68C5355D E4861390 2A2DFB87 1044E395

B871B85C 4D817FA3 87297455 27D63D50 7675F75B E869367A EF4FDE27 1C9A0D8E

A3F3B633 7A

quit

!

!

!

!

!

spanning-tree mode pvst

spanning-tree extend system-id

!

vlan internal allocation policy ascending

!

!

!

interface FastEthernet0/1

!

interface FastEthernet0/2

!

interface FastEthernet0/3

!

interface FastEthernet0/4

!

interface FastEthernet0/5

!

interface FastEthernet0/6

!

interface FastEthernet0/7

!

interface FastEthernet0/8

!

interface FastEthernet0/9

!

interface FastEthernet0/10

!

interface FastEthernet0/11

!

interface FastEthernet0/12

!

interface FastEthernet0/13

!

interface FastEthernet0/14

!

interface FastEthernet0/15

!

interface FastEthernet0/16

!

interface FastEthernet0/17

!

interface FastEthernet0/18

!

interface FastEthernet0/19

!

interface FastEthernet0/20

!

interface FastEthernet0/21

!

interface FastEthernet0/22

!

interface FastEthernet0/23

!

interface FastEthernet0/24

!

interface GigabitEthernet0/1

media-type sfp

!

interface GigabitEthernet0/2

media-type sfp

!

interface Vlan1

ip address #.#.#.# 255.255.255.0

no ip route-cache

!

ip default-gateway #.#.#.#

ip http server

ip http secure-server

!

control-plane

!

!

line con 0

line vty 0 4

password ###############

login

line vty 5 15

password ###############

login

!

end

Share this post


Link to post
Share on other sites

Well I don't know SFP but you don't have that port setup at all.

eg;

int gi0/49
switchport mode trunk
switchport trunk encapsulation dot1q
switchport trunk native vlan 1

Or whatever you want.

Share this post


Link to post
Share on other sites

Well I don't know SFP but you don't have that port setup at all.

eg;

int gi0/49
switchport mode trunk
switchport trunk encapsulation dot1q
switchport trunk native vlan 1

Or whatever you want.

I'm trying to set it up for fibre, I've never worked with the IOS in switches, only routers. Can someone give me the commands I need? I only want a basic setup

Edited by njbignell

Share this post


Link to post
Share on other sites

A couple of assumptions here...

 

1. The fibre is plugged in at the other end, and you *know* that interface is/was operational

2. The fibre is undamaged

3. You have the fibre plugged in correctly at all joins (i.e. rx > tx, tx > rx)

4. You are using compatible fibre (in this case, it looks like multimode is the go...)

 

unless you have the above, you won't get the link light showing

 

with regards to your port config, the switch has recognised the module, so I don't think there is a problem with your switch or sfp.

 

A test I have employed to check MULTIMODE fibre, is to plug it in, and very carefully look at the end. You should see light coming out one end. Plug in the other way around, and repeat.. (and yes, the LC connector can be swapped around, it is just a bracket holding the fibre ends in place, its a sort of twist, and it will come free.) btw, NEVER do the above with single mode, the light / laser is way more intense, and a very high likely hood of blindness if you look directly into the end of a lit single mode fibre...

Edited by garlic

Share this post


Link to post
Share on other sites

A couple of assumptions here...

 

1. The fibre is plugged in at the other end, and you *know* that interface is/was operational

2. The fibre is undamaged

3. You have the fibre plugged in correctly at all joins (i.e. rx > tx, tx > rx)

4. You are using compatible fibre (in this case, it looks like multimode is the go...)

 

unless you have the above, you won't get the link light showing

 

with regards to your port config, the switch has recognised the module, so I don't think there is a problem with your switch or sfp.

 

A test I have employed to check MULTIMODE fibre, is to plug it in, and very carefully look at the end. You should see light coming out one end. Plug in the other way around, and repeat.. (and yes, the LC connector can be swapped around, it is just a bracket holding the fibre ends in place, its a sort of twist, and it will come free.) btw, NEVER do the above with single mode, the light / laser is way more intense, and a very high likely hood of blindness if you look directly into the end of a lit single mode fibre...

Yeah I've tried averything you suggested there and everything seems to be working fine, but thanks anyway. I'm fairly certain it has something to do with the configuration in the IOS.

Edited by njbignell

Share this post


Link to post
Share on other sites

this:

 

Full-duplex, 1000Mb/s, link type is auto, media type is 1000BaseSX SFP

 

says otherwise...

Share this post


Link to post
Share on other sites

There really is nothing you need to configure in order to get a link, just plug in the cable at both ends and away you go. To double check this I just checked our old 2960 configs for SFP configuration and there is nothing.

 

What is on the other end of the cable? Is it the same type of SFP module or is it something else?

Share this post


Link to post
Share on other sites

There really is nothing you need to configure in order to get a link, just plug in the cable at both ends and away you go. To double check this I just checked our old 2960 configs for SFP configuration and there is nothing.

 

What is on the other end of the cable? Is it the same type of SFP module or is it something else?

The other end goes into a media converter (RJ45) and then into the RJ45 Gigabit uplink on another switch.

 

After I set the speed negotiation to auto the fibre side of the media converter lit up but still nothing lights up on the SFP port of the switch.

 

Ill try get in there before anyone arrives tommorow and try a different port (all the uplink ports are taken bar one so I'll have to disconnect part of the network to try anything)

Share this post


Link to post
Share on other sites

My guess would be either faulty fibre, faulty SFP or faulty switch. I would start with the fibre myself. The media converter is possibly giving a link indication because it is receiving light, and the SFP isn't or similar

 

there isn't anything else you can configure on a 2960 to enable the SFP other than specifying the media-type (afaik) (the other media-type being a GLC-T or 1000Base-T interface) and this is only optional, I have rarely had a problem leaving the media-type unconfigured, and letting the switch work itself out...

Share this post


Link to post
Share on other sites

Can I see a show version and could you also include the cisco part number for the sfp? Also they brand / model of the media converter would also be handy.

Share this post


Link to post
Share on other sites

Can I see a show version and could you also include the cisco part number for the sfp? Also they brand / model of the media converter would also be handy.

I'll post it all for you in the morning

Share this post


Link to post
Share on other sites

TRCSWI04#show version

Cisco IOS Software, C2960 Software (C2960-LANBASEK9-M), Version 12.2(44)SE6, RELEASE SOFTWARE (fc1)

Copyright © 1986-2009 by Cisco Systems, Inc.

Compiled Mon 09-Mar-09 18:10 by gereddy

Image text-base: 0x00003000, data-base: 0x01100000

 

ROM: Bootstrap program is C2960 boot loader

BOOTLDR: C2960 Boot Loader (C2960-HBOOT-M) Version 12.2(44)SE6, RELEASE SOFTWARE

(fc1)

 

TRCSWI04 uptime is 33 minutes

System returned to ROM by power-on

System image file is "flash:c2960-lanbasek9-mz.122-44.SE6/c2960-lanbasek9-mz.122-44.SE6.bin"

 

........

........ << Boring Stuff

........

 

cisco WS-C2960-24TC-L (PowerPC405) processor (revision J0) with 61440K/4088K bytes of memory.

Processor board ID FOC1409V50L

Last reset from power-on

1 Virtual Ethernet interface

24 FastEthernet interfaces

2 Gigabit Ethernet interfaces

The password-recovery mechanism is enabled.

 

64K bytes of flash-simulated non-volatile configuration memory.

Base ethernet MAC Address : 08:1F:F3:6C:25:80

Motherboard assembly number : 73-11437-07

Power supply part number : 341-0097-02

Motherboard serial number : FOC14095C2N

Power supply serial number : DCA14078EGY

Model revision number : J0

Motherboard revision number : B0

Model number : WS-C2960-24TC-L

System serial number : FOC1409V50L

Top Assembly Part Number : 800-29826-03

Top Assembly Revision Number : E0

Version ID : V06

CLEI Code Number : COMFT00BRA

Hardware Board Revision Number : 0x01

 

 

Switch Ports Model SW Version SW Image

------ ----- ----- ---------- ----------

* 1 26 WS-C2960-24TC-L 12.2(44)SE6 C2960-LANBASEK9-M

 

 

Configuration register is 0xF

Share this post


Link to post
Share on other sites

To me it sounds a little like a faulty cable somewhere along the line.

 

Can you post a "show inventory"? Blank out the serial numbers if needed. Also, the model of the media converter would be useful.

 

What type of cable are you using? Is it the same all along the line?

Share this post


Link to post
Share on other sites

I am assuming the media converter is quite a distance away from the switch (perhaps inter floor)? The WS-C2960-24TC-L has 2 dual purpose gig links. Meaning while there are four ports, only two can be used. If the other switch is in the same room, I would just run copper and be done with it.

 

The media-type sfp command selects between the copper and sfp port, so regardless of how its physically connected it should still work... at a bit of a loss here to be honest

 

Did you end up being able to test the sfp / fibre on another port?

Share this post


Link to post
Share on other sites

I am assuming the media converter is quite a distance away from the switch (perhaps inter floor)? The WS-C2960-24TC-L has 2 dual purpose gig links. Meaning while there are four ports, only two can be used. If the other switch is in the same room, I would just run copper and be done with it.

 

The media-type sfp command selects between the copper and sfp port, so regardless of how its physically connected it should still work... at a bit of a loss here to be honest

 

Did you end up being able to test the sfp / fibre on another port?

It's in the same room at the moment but we'll be deploying it shortly. I've got CISCO calling me again today but they don't seem to know what going wrong either

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×