Jump to content
.:Cyb3rGlitch:.

Android users ahoy!

Recommended Posts

Still need testers?

 

Have a Nexus One with Android 2.3.4

 

Your app looks interesting. Are you available for Android contract work?

The more testers the merrier. :) I'll just need your DropBox email.

 

I haven't thought about contract work, the original purpose of this app was to learn about the platform, but it worked so well that I decided to keep at it. I'm busy with uni at the moment, but otherwise I'm open to offers. :p

Share this post


Link to post
Share on other sites

Ok, new UI is live.

 

EDIT: Oh, and I'm curious to know if the UI appears properly on different screen sizes and resolutions!

Edited by .:Cyb3rGlitch:.

Share this post


Link to post
Share on other sites

I ended up getting it off the market (you just scored a $1) but I've since had to un-install it had an odd issue:

 

After installing I noticed that the email app no longer accepted touch input! After un-installing it worked fine again, not entirely sure why.

 

Will try installing your new version see if the issue appears again.

Share this post


Link to post
Share on other sites

I ended up getting it off the market (you just scored a $1) but I've since had to un-install it had an odd issue:

 

After installing I noticed that the email app no longer accepted touch input! After un-installing it worked fine again, not entirely sure why.

 

Will try installing your new version see if the issue appears again.

Is this the default e-mail app?

 

Yep, sign me up too.

 

But I won't be able to test it until tomorrow. It's way past my bed time :P

What e-mail do you use for DropBox?

Share this post


Link to post
Share on other sites

Yep, sign me up too.

 

But I won't be able to test it until tomorrow. It's way past my bed time :P

What e-mail do you use for DropBox?

 

aaron at charcoalstyles.com

 

I just started using Dropbox yesterday :P

Share this post


Link to post
Share on other sites

Ok, new UI is live.

 

EDIT: Oh, and I'm curious to know if the UI appears properly on different screen sizes and resolutions!

Looks perfect on my phone. All components are sized correctly and nothing is cut off. I like the new buttons. Much easier to use than the previous ones. This version also updated without having to first uninstall the previous one.

Share this post


Link to post
Share on other sites

Cool. :)

 

I've actually changed the UI slightly again, after learning a few vector art techniques.

 

Posted Image

 

(The second row of images are the new pop-up dialogues that appear when you add the widget to a home screen. First button activates tutorial mode, the second runs through steps to calibrate Lux, and the third goes straight to the Dashboard.)

Share this post


Link to post
Share on other sites

I ended up getting it off the market (you just scored a $1) but I've since had to un-install it had an odd issue:

 

After installing I noticed that the email app no longer accepted touch input! After un-installing it worked fine again, not entirely sure why.

 

Will try installing your new version see if the issue appears again.

Is this the default e-mail app?

 

Yep was the default e-mail app. Is strange, have not yet gotten round to installing it again.

Share this post


Link to post
Share on other sites

Yep was the default e-mail app. Is strange, have not yet gotten round to installing it again.

From what I could gather, it's a bug with GMail. Other apps are having the same issue, such as Screen Filter. Apparently the latest version of GMail fixes the problem.

 

 

Also, for tablet owners, try the latest build. I implemented hardware acceleration application wide, so hopefully that fixes any lag issues!

Share this post


Link to post
Share on other sites

Nothing to report from a cell phone perspective. It's been playing very nicely in the background so far. The new version installed without extra persuasion. I reinstalled the widget just to check out the howdy stranger message :)

 

So far, the app is only limited by my phone's capabilities. Looks good, works well.

 

Oh ... And BTW, happy birthday !

Edited by NightOwl

Share this post


Link to post
Share on other sites

Thanks. :)

 

Well my other testers claim that the GPU acceleration doesn't help, so it looks like it's back to the drawing board this weekend. Might have to pick some brains over at SO.

Share this post


Link to post
Share on other sites

Well you have some feedback from me in the other forum, however as I am much more frequently here, I will use this thread in future.

 

I've installed it last week and other than the ui display issues i mentioned, haven't noticed much else out of place.

 

I have however noticed it uses around 10-15% battery on a daily basis.

 

* I've turned on/off auto adjust over the last few days to see if this changed (@ default refresh rate) and this didn't effect it much, dropped a little perhaps, from closer to 15 to closer to 10 on average.

 

* I've also turned off the notification, which makes zero difference.

 

* I do use the auto adjust on display activate feature.

 

* I basically configured it on the first day and just let it do its thing now, so I haven't been fiddling with it constantly or anything.

 

As you were interested in battery usage, hope this helps.l Have been running it for about a week now, and every day it shows up around the same usage.

Share this post


Link to post
Share on other sites

You're running a SGSII right? For some reason that phone attributes battery usage to my app wrongly, because no other phone has this issue, and SGSII users have reported this before. Have you actually noticed your battery life being shortened? I'd love to know why this occurs, though. :/

 

Well you have some feedback from me in the other forum, however as I am much more frequently here, I will use this thread in future.

 

I've installed it last week and other than the ui display issues i mentioned, haven't noticed much else out of place.

 

I have however noticed it uses around 10-15% battery on a daily basis.

 

* I've turned on/off auto adjust over the last few days to see if this changed (@ default refresh rate) and this didn't effect it much, dropped a little perhaps, from closer to 15 to closer to 10 on average.

 

* I've also turned off the notification, which makes zero difference.

 

* I do use the auto adjust on display activate feature.

 

* I basically configured it on the first day and just let it do its thing now, so I haven't been fiddling with it constantly or anything.

 

As you were interested in battery usage, hope this helps.l Have been running it for about a week now, and every day it shows up around the same usage.

Share this post


Link to post
Share on other sites

Yea i am using an SGSII. No i usually get about 18hrs before it warns me its low, and this hasn't changed much. So I don't think it is really draining much extra battery. You are probably correct that it is just reporting the incorrect usage.

 

I will try to pay a bit more attention to it, or play with the settings some more, and see if this has any effect.

Share this post


Link to post
Share on other sites

It could very well be using that much battery, but that'd mean the SGSII has some unique set up where something in my app causes it to consume battery for no good reason. Perhaps as an experiment, download and use Screen Filter, and see if that also reports a high battery usage. All that app does is put a static overlay over the screen - i.e. it doesn't actively do anything.

 

Yea i am using an SGSII. No i usually get about 18hrs before it warns me its low, and this hasn't changed much. So I don't think it is really draining much extra battery. You are probably correct that it is just reporting the incorrect usage.

 

I will try to pay a bit more attention to it, or play with the settings some more, and see if this has any effect.

Share this post


Link to post
Share on other sites

Ok, installed. Will give it another day or two and see how I go. If there are any settings you want to specifically test feel free to let me know.

Share this post


Link to post
Share on other sites

Just make sure you have Screen Filter on with a very low darkness to ensure the screen overlay is actually on. That's the only test I need for now - thanks for the assistance!

Share this post


Link to post
Share on other sites

I just uploaded a new build. I'd like to know if the tutorial and calibration modes work/display properly. For some reason entering the tutorial a second time closes everything, otherwise everything else *should* work.

Share this post


Link to post
Share on other sites

I had a theory last night, as to why SGSII might cause lux to use more power.

 

Having such a big screen, in the battery usage report, screen usually accounts for 45-50% of all usage daily.

I thought that this may somehow effect the readings... however..

 

Last night after about 19hours on battery before plugging it in (I installed screen filter at about 4 or 5 hours on battery) Lux still using 13% battery and screen filter (at 60% darkness) didn't get a mention in the report.

 

Today i've only just taken it off battery 2 hours ago, and display is at 11% usage as it didn't get used much when I was asleep. Lux is reporting 21% though.. so not sure that may blow my theory out of the water. Screen filter still at 60% darkness doesn't get a mention in the report.

 

Will load up the new build tonight.

Edited by p0is(+)n

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×