Jump to content
.:Cyb3rGlitch:.

Android users ahoy!

Recommended Posts

So far so good, looks like we're back on track.

ok installed newest build and using default settings. will see how i go :)

actually very much like this app btw, i find the default brightness can be hideously ugly at times.

Share this post


Link to post
Share on other sites

Attempting to upload a screenshot now showing about 40 hours use over the weekend. Doesn't seem to have changed much, still about 12% overall battery. Keeps failing though so may have to wait.

 

I no longer use the homescreen widget, nor the periodic adjust, but do have adjust on screen wake up activated, and also have the notification turned on. So I am not sure what it is really doing to consume 12% of my battery. My display comes in at 14% and I am sure it must use a lot more power...

 

Generally my backlight is set to 15-30%, I don't know if that will play any part in the amount of usage. Any suggestions for features to turn on/off, I would be happy to test.

 

Slightly off topic, I was surprised to see just how long the battery on this phone does last when I don't use it all day.

 

EDIT:

Uploaded: http://i1196.photobucket.com/albums/aa420/...26-015003-3.jpg

Edited by p0is(+)n

Share this post


Link to post
Share on other sites

Hmm... I really don't know what is causing the reported usage to be that high. I think I might contact the guy that wrote Screen Filter and see if he's willing to lend me a hand (big 'if' there, but you never know.).

Edited by .:Cyb3rGlitch:.

Share this post


Link to post
Share on other sites

The latest Dropbox build has the ability to manually edit linked samples!

 

Posted Image

 

You might also notice that the colour temperature of the screenshot is warmer than usual - that's the new 'night mode' feature I'm working on. It's works a bit like F.lux.

Edited by .:Cyb3rGlitch:.

Share this post


Link to post
Share on other sites

The night mode screen tint is hardly noticeable on my phone. I don't seem to be able to make it as dark as your example.

 

Also, backup/restore is no longer under the sub menu specified in the settings. Had me confused for a moment .... was trying to scroll down to a setting that didn't exist :) Found it eventually !

Share this post


Link to post
Share on other sites

I made the night mode a lot less intense. I think I made it too subtle though.

 

Apparently the new seekbar on the dashboard renders oddly on some devices, so I have to fix that too.

Share this post


Link to post
Share on other sites

Haven't been following this thread recently, so have not used the latest build since I posted previously that i had installed it. After monitoring it a little more, battery use is mostly between 8-10%, and only higher if I don't use any other apps on my phone that particular day. The more I use my phone, the lower it seems to get, so it may just be that is is using fuck all battery, but so is the rest of my phone so proportionatly it appers higher.

 

I will install the latest build tonight and keep an eye on things.

Share this post


Link to post
Share on other sites

Ok, just updated the Dropbox with a new build. This one is feature complete! Just need to polish it off, put out one more beta to the Marketplace, then if all is swell... it goes gold! :D

 

New features include:

- Continuous data filtering - you no longer have to wait!

- Holding down 'refresh' on the Dashboard toggles periodic mode

- Linked sample editor no longer displays duplicates (because they no longer exist)

Share this post


Link to post
Share on other sites

One thing that stands out is the new astro mode intensity. I'm finding the shade of red overwhelming and is definitely a bit too bright for my taste. It may be my imagination, but sub zero seems to look better. Low light setting, but crystal clear.

 

I like the dashboard though. The multi function buttons are a good idea and work well. I like the button highlights too. Together with the status line, it makes a nicely polished action validation. The tags under the seek bar however, are unreadably tiny on my phone.

 

This app performs beautifully on my phone and has happily maintain my preferred backlight levels without a single hitch. I originally thought I would probably delete it after the testing period was over, but I really like it and can't imagine not having this app. This is certainly something I'd purchase and recommend it to others.

 

I've only just installed the latest version and will let you know if I discover anything else noteworthy :)

Share this post


Link to post
Share on other sites

Thanks for the feedback. :)

 

I did change sub-zero slightly a few builds back, and astro mode recently. I think I'll leave it intense, since many users were complaining that it wasn't red enough. Really it's supposed to be used in tandem with sub-zero, so it actually works well that way.

 

I'm still getting my head around supporting different screen sizes. I thought I was doing it correctly, but it turns out I still need to tweak a few things. That'd explain the tiny slider guide.

 

The new ICS theme is a bit of a pain though, semi-transparent black just isn't working as well as I had hoped. It blends in too well with dark windows behind it.

Share this post


Link to post
Share on other sites

Huh, it doesn't look semi transparent on my phone ... just looks plain black. The smaller display must be affecting the intensity. But it looks brilliant with the light coloured theme I'm using :)

Share this post


Link to post
Share on other sites

Ok, another update!

 

I tweaked the theme a little so that it doesn't blend into dark backgrounds completely. Makes it easier to see when opened in the app drawer etc.

 

Let me know if you still have the issue of text being too small NightOwl. I need to submit this app to a competition in a couple of days! D:

Share this post


Link to post
Share on other sites

Will do.

 

But I actually came to report another interesting observation .... I've started seeing what p0is(+)n reported about battery usage. My battery monitor is reporting very high battery usage by Lux .... currently up to 67%. This started happening since the last update, but when I updated, I also turned on periodic adjustment.

 

BUT, my *actual* battery life hasn't changed.... ie; charge cycle is the same. So I can only assume something has corrupted the data feeding the monitoring app ... and I say the data feeding the app, because two different battery monitoring apps report the same usage.

 

It's very odd. Still trying to figure out a way to reset it. I'm going to delete, recharge and reinstall everything tonight when I get home.... see if that makes a difference.

 

update; ... I couldn't wait. I've deleted, reboot and reinstalled. Lux has disappeared off my battery monitor. If Lux doesn't reappear, I'll try again with periodic adjustment turned on.

 

... and the text on the dashboard is now readable :)

Edited by NightOwl

Share this post


Link to post
Share on other sites

Huh, interesting. I haven't noticed much battery use myself. I'll look into it.

 

Well my to-do list for Lux has blown out completely now. I'm not happy with its complexity, so I'm going to try a few techniques to simplify the process. I'm thinking of having two modes, simple and advanced. However, my idea of 'simple' is very complex to implement.

Share this post


Link to post
Share on other sites

The thing is .... it's not actually using extra power. It's only reported as doing so. That's the odd part. I've been manually monitoring my battery usage and it hasn't changed. A true 67% usage would be very noticeable.

Share this post


Link to post
Share on other sites

Yeah, there's nothing I can do about that. It's really annoying because I get e-mails from people complaining about it.

 

Anyway, here's a sneak peak at the new tutorial system for Lux.

 

Posted Image

Edited by .:Cyb3rGlitch:.

Share this post


Link to post
Share on other sites

Lux is registering on my battery monitor again. It's supposedly using 70% of the charge.... which I know is not correct, else my battery life would halve. Period between charges remains unchanged. I've tried everything and can't account for it. Very strange.

Share this post


Link to post
Share on other sites

I'll have to investigate further. It's low priority for me at the moment, because I know it'll take forever to find the issue, and chances are it can't be fixed on my end.

 

I'm currently busy re-doing the tutorial stuff. Here's a screenshot of the slash page I'm implementing.

 

Posted Image

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×