Jump to content
Bala_Matt

BF3 Benchmarking

Recommended Posts

Hi All,

 

I've finished reading Tom's benchmarks and it doesn't match my experience. I've been using FRAPS and think my system is performing faster.

 

What's your experience?

Share this post


Link to post
Share on other sites

I'm running almost all things at ultra. AA is off and shadows on medium.

 

This is on a GTX280.

 

 

I'm thinking of maybe just getting a 570 instead of a 580 now.

Share this post


Link to post
Share on other sites

Don't know, don't care.

 

It's smooth, looks nice, and that's all I give a shit about. :)

Share this post


Link to post
Share on other sites

im very interested in what people get..especially people at 1440/1600p res..

 

can help me decide what GPU i need.

Share this post


Link to post
Share on other sites

Mine is smooth as a baby's bottom at 1680x1050 & 1920x1080. This is on almost all Ultra settings. I'm happy to test certain settings on request if anyone would like.

 

I have

GTX 570 Gigabyte OC

i5 2600k on Z68 board

2x4gb G.Skill Ripjaws

Hard drive NOT SSD

 

and FRAPS :)

Edited by Bala_Matt

Share this post


Link to post
Share on other sites

im very interested in what people get..especially people at 1440/1600p res..

 

can help me decide what GPU i need.

Looking at your sig I'd say HD6950 or GTX 560/570.

 

I have an ASUS HD6950 2gb (with i7 920 @ 3.6Ghz, 6gb 1600MHz DDR3) running at 1920x1080, everything is high, some things on ultra (auto settings), no AA... dunno what FPS I get as I've never bothered to check, but it looks and feels smooth and never stutters or bogs down.

 

So I am content. :)

Edited by Ezkaton

Share this post


Link to post
Share on other sites

im running a 2600k with a GTX460 on a 47 LED @ 1080p 60hz and it isnt skipping a beat, with GFX settings on high,, tho when i get home ill try ultra, tho i had to reboot my router twice so i could re logon :-(

Edited by tuner

Share this post


Link to post
Share on other sites

What's interesting about that article is that they claim all GeForce cards before the 400 series (all DirectX 10 cards basically) show some hideous problems with shadows. And CrossfireX broke with the launch update

Share this post


Link to post
Share on other sites

im very interested in what people get..especially people at 1440/1600p res..

 

can help me decide what GPU i need.

Looking at your sig I'd say HD6950 or GTX 560/570.

 

I have an ASUS HD6950 2gb (with i7 920 @ 3.6Ghz, 6gb 1600MHz DDR3) running at 1920x1080, everything is high, some things on ultra (auto settings), no AA... dunno what FPS I get as I've never bothered to check, but it looks and feels smooth and never stutters or bogs down.

 

So I am content. :)

 

a 560? u mad bro? :P

 

this aint 1080p im runin...

 

im tossing up between a 3GB or 1.5GB 580...im not a nvidia fan i just stick with what works thats all.

 

So anyone got any more results?

Edited by jdog

Share this post


Link to post
Share on other sites

im very interested in what people get..especially people at 1440/1600p res..

 

can help me decide what GPU i need.

Looking at your sig I'd say HD6950 or GTX 560/570.

 

I have an ASUS HD6950 2gb (with i7 920 @ 3.6Ghz, 6gb 1600MHz DDR3) running at 1920x1080, everything is high, some things on ultra (auto settings), no AA... dunno what FPS I get as I've never bothered to check, but it looks and feels smooth and never stutters or bogs down.

 

So I am content. :)

 

a 560? u mad bro? :P

 

this aint 1080p im runin...

 

im tossing up between a 3GB or 1.5GB 580...im not a nvidia fan i just stick with what works thats all.

 

So anyone got any more results?

 

iirc the GTX560TI does quite well on the frostbite engine, cheaper to.

 

honestly though theres nothing here to debate, get a HD6950 2gb and be done with it.

Share this post


Link to post
Share on other sites

2560x1440 aa off motion blur off post process off

gtx480 sli only just manage to keep it over 60fps in some places

with vsync enabled gpu load seems to very from ~50% to 100%

cpu usage is only ~50% with ht disabled

Share this post


Link to post
Share on other sites

Anyone with a dual core playing? I know BC2 was terrible on a dual core but may be they have fixed this?

Dual 3.2ghtz + 5770 = 1280x1024 @ Low = min-avg 25/40+ fps

Share this post


Link to post
Share on other sites

does it lag when buildings are falling down though? I guess there isn't much to fall down anymore since nothing breaks.

Share this post


Link to post
Share on other sites

Anyone with a dual core playing? I know BC2 was terrible on a dual core but may be they have fixed this?

Yeah beta was unplayable for me wiht constant lockups and sound loops. I have an e8500 stock and 5850 (see sig). I run at 1680x1050 on high. I get around 25-30fps but every now and then I get shuddering for a second or 2, looks like 1-5fps and then seems to run smooth again for quite some time.

 

For me it is ok enough that I am holding off upgrading until Jan, when I have some more coin, but initially I thought I was going to have to upgrade straight away.

 

Probably most worthwhile would be an SSD, long load times for levels and maps is really apparent with my Samsung F1.

 

Tye

Share this post


Link to post
Share on other sites

For some reason my rocket sounds are sometimes delayed. Like you get the rocket shot at you. You miss it it explodes. And then as you walk past the explosion site, then the swooping rocket flying past sound happens. lol?

Share this post


Link to post
Share on other sites

i am a little dissapointed in the damage not done to the surroundings, i liked the bfbc2 engine better i think. when i get home later ill run fraps with crossfire 6970's and a single gpu.

Share this post


Link to post
Share on other sites

Anyone with a dual core playing? I know BC2 was terrible on a dual core but may be they have fixed this?

Yeah beta was unplayable for me wiht constant lockups and sound loops. I have an e8500 stock and 5850 (see sig). I run at 1680x1050 on high. I get around 25-30fps but every now and then I get shuddering for a second or 2, looks like 1-5fps and then seems to run smooth again for quite some time.

 

For me it is ok enough that I am holding off upgrading until Jan, when I have some more coin, but initially I thought I was going to have to upgrade straight away.

 

Probably most worthwhile would be an SSD, long load times for levels and maps is really apparent with my Samsung F1.

 

Tye

 

Yeah i had a Q6600 @ 3.2ghz with 4gb ram, P5Qpro and running a Gigabyte 5850. i found the same jumping on mid-high settings and couldnt stand it so i bit the bullet and upgraded today to a i5 2500K on a Gigabyte Z68 UD3R and kept the 5850 and it runs as smooth as anything, i noticed the jumpyness on my old rig mainly when i was in areas with alot of people around.. the whole upgrade only cost $470 so its not too bad.

Share this post


Link to post
Share on other sites

Here is a quick benchmark i did. All settings Ultra

 

2011-10-29 10:25:34 - bf3

Frames: 11659 - Time: 190883ms - Avg: 61.079 - Min: 40 - Max: 97

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×