Jump to content
savvart

Graphics Cards Fan spins at full Speed

Recommended Posts

Hi all,

 

My new computer was running beautifully.

 

Then all of a sudden the GPU fan begins spinning at full speed for no reason for about 2 - 8 mins then slows down again.

 

That has happened a few times and now if I don't turn my machine off for at least 10 minutes it spins madly continuously once it starts going 'spinning' mad.

 

I have a Galaxy Geforce 670 with 2GB DDR5 and it is 10 days old...

 

It does not spin super fast because it is overheated as the case is so very cool and even if I open it up it continues to spin fast - once it kicks into it's fast moments...

 

ANY ideas?

 

I have tried using Galaxy's Xtreme Tuner to control the fan but it does not work once the fan speed goes mental. It does work in normal use as I can manually change the fan speed and you can hear it working and changing.

 

Thanks for any advice.

Share this post


Link to post
Share on other sites

Try drivers, the CD that came with the card is outdated (as you may or may not know).

 

Failing that you might have to contact the store you purchased from and enquire about a fix.

Share this post


Link to post
Share on other sites

Out of curiosity can you post the temps it is reporting, even if you think your case has sufficient cooling?

As it happens after a few minutes, I would suspect heat or perhaps an incorrect installation of the cooler (presumably at the factory).

 

Assuming drivers/firmware is up to date, I would suggest something like afterburner to set your own fan speed profile and see what happens, keeping an eye on temps.

Share this post


Link to post
Share on other sites

Well it seems pretty fine now. After 2 days of use not a single mad fast spinning fan on the GPU...

 

What I did was:

 

I removed the card and reinstalled it and then updated (again, as it was already the latest) drivers from nVidia. Bang, no more issues...

 

As for temperatures - the highest it got to was 55 degrees and that was after a 3 hour marathon with Far Cry 3 with ALL options set to ultra.

 

The only thing that happened was the fan began to speed up a bit more during the game for a few minutes (and the air coming out was quite hot) and then dropped back to a normal low level again.

 

Thx for the advice all...

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×