Jump to content
Sign in to follow this  

7970 stuck at 500MHz clocks problem and solution

Recommended Posts

I've got a MSI 7970 Lightning, which has been great - however, recently, it was very slow in games and seemed to have serious problems with clock speed never increasing from 500MHz, either up or down.


This led to reduced performance in everything, though the UVD video processing still worked for flash vids on youtube.


I did a full uninstall of the 13.4 drivers (driver sweeper/driver fusion, ccleaner, etc), tried the beta 13.6 drivers, tried every setting I could find, and even used a tool to disable the Ultra Low Power Saver (ULPS tool here) but nothing worked. Here's a screenshot (click to embiggen):


Posted Image


After looking through many forum posts (and I've actually lost the post I read it in) someone mentioned that MSI Afterburner can cause sticky clocks like I'd experienced. I had the latest version installed - v2.3.1 - but had always installed new versions over older ones. Totally uninstalling Afterburner worked immediately!


I've since installed beta 11 of Afterburner v3 and it's exhibiting none of the old problems. Clocks now idle at 300MHz and jump up as necessary when in games or other demanding content. I did not remove the profiles or settings when uninstalling Afterburner v2.3.1.


Posted Image


The only problem I'm having is in getting the UVD video enhancements to kick in when watching youtube fullscreen, it works if I change a slider setting even by a single increment, but I think it's probably due to the beta driver rather than Afterburner. If anyone knows otherwise I'd love to hear a solution.


So I hope that helps another 7970 user out there :)

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this