Jump to content
Sign in to follow this  
ugotdan

Help with tri fire HD6970

Recommended Posts

Ok so I've been holding off on setting these up for over a month now as I've been waiting for another card, but it looks like that's a fail. So, I set these up last night and had a quick play while running the bubbles out of my wc loop. MSI afterburner is reading 3 cards ok. I opened CCC to setup Xfire and I'm only getting use of two cards. There didnt seem to be an option for 3 cards. I started arma 3 just to see but again, only 2 cards being used. This is a first trifire for me. What are the initial steps I should be checking to get these three cards running together?

I don't have a screeny yet but took a pic of my rig with my phone :)

Posted Image

Share this post


Link to post
Share on other sites

try 3dmark and look at gpu usage in afterburner for each gpu

Share this post


Link to post
Share on other sites

I enabled xfire in CCC but went into overdrive screen and only found it reporting two cards in the drop down box.

No haven't checked the clocks I just ran arma 3 home screen and alt tabbed over to see gpu usage. Gpu 1&2 were up at 80 while gpu 3 was not in use.

Share this post


Link to post
Share on other sites

some games wont benefit from the third gpu which is why i suggested 3dmark

and the fact that its only using 80% of two gpu means your probably cpu limited in arma anyway and even if the third was working it wouldnt help fps

it could just be that crossfire sucks in arma 3 at the moment

 

you have fully uninstalled the drivers and reinstalled them after installing the third card?

Edited by Dasa

Share this post


Link to post
Share on other sites

you have fully uninstalled the drivers and reinstalled them after installing the third card?

No I didn't! That is a great starting point too :D that's exactly what I'm looking for - good call. (I realize not many games will really utilize the 3rd gpu but arma is probably the best I have ATM in regards to a gpu taxing game.) Just wanted to see smoooooth sexiness lol ;)

 

I'll start there and let you know how it turns out. Cheers

Share this post


Link to post
Share on other sites

OK I have removed and re-installed CCC and profiles to latest. Still no go for my Xfire 3-way.

My CCC - Information - Hardware tab reports Primary adapter and Linked adapter but also has Disabled adapter.

Device manager shows 3 6900 series display adapters and all drivers are up to date.

GPU-Z recognizes all 3 cards as well.

Anyone know how to "enable" this 3rd card in CCC??

Share this post


Link to post
Share on other sites

CCC isnt a nice program.

 

Did you confirm its truly not being used at all as was suggested above?

3Dmark + afterburner, to check that its not using it and CCC just THINKS its not?

 

Remember CCC isnt the driver as such, its a tool. Just like afterburner.

If windows says 3 are active, and Afterburner says 3 are active. I'd be more inclined to trust it, than anything else.

 

But a benchmark while monitoring clocks will tell you.

Share this post


Link to post
Share on other sites

CCC isnt a nice program.

 

Did you confirm its truly not being used at all as was suggested above?

3Dmark + afterburner, to check that its not using it and CCC just THINKS its not?

 

Remember CCC isnt the driver as such, its a tool. Just like afterburner.

If windows says 3 are active, and Afterburner says 3 are active. I'd be more inclined to trust it, than anything else.

 

But a benchmark while monitoring clocks will tell you.

 

Yep I benched it and only one is being utilized. Afterburner reports +98% on the primary in full screen (multi monitors 3600x1920 portrait) and no load on the second and third cards. I started up arma 3 again and two cards are under +98% load at ultra settings (20fps lol) :p so xfire is working.

I'll post a screeny tonight.

One person mentioned doing a factory reset on CCC is another option to try?

Are there any other programs/tools recommended over CCC that I can use to enable tri fire?

Could it be eyefinity preventing it?

I know CCC should have a drop down to enable 3way xfire but I don't get that. I just get the dot option to enable xfire.

 

Man, this is a bit of a doozy :p

Edited by ugotdan

Share this post


Link to post
Share on other sites

woahwoahwoah.... yes, eyefinity.

 

If you wish to crossfire cards, generally speaking you should run your multiple monitors (usually max of 3) from the PRIMARY card, as the others just 'help' it along.

If you run monitors off each card, you'll have them switch into non-crossfire mode and act as individual adaptors.

At least, this is my experience.

 

For a shot in the dark... is the 'disabled' card, running a monitor? where as, of the two that manage to crossfire in CCC, only one card is, and the other is 'empty'?

This could be it.

Share this post


Link to post
Share on other sites

Cool, I'll def check that one out. Not sure how to do that. Maybe I will disable eyefinity and try it all on the one screen??

Share this post


Link to post
Share on other sites

Posted Image

 

OK so I have done a few things since last post.

I changed the crossfire bridges around (not a show stopper, I know they both work.)

I disabled eyefinity and had my screens in extended mode.

I removed CCC and uninstalled/deleted all the graphics cards drivers. Reset, reinstall.

tried again and..... no go :(

The above pic shows Afterburner reporting two cards under load during a bench using Heaven (3dmark I purchased throgh steam not working... another saga I'm sure...) It also shows the Driver manager reports 3 GPUs and they have all the latest drivers. You can see CCC reporting 2 active adapters and one disabled adapter. some various other apps I was watching during benching I'm sure you're all familiar...

Pic below shows CCC only allowing me to enable xfire. No dropdown is available to enable 3 way xfire.

Posted Image

 

Fuck me.

Edited by ugotdan

Share this post


Link to post
Share on other sites

whats your mb?

if you plug a display into the third gpu instead of all into the first one can it at least display through it to confirm its working ok out of crossfire?

Edited by Dasa

Share this post


Link to post
Share on other sites

whats your mb?

if you plug a display into the third gpu instead of all into the first one can it at least display through it to confirm its working ok out of crossfire?

mobo - http://www.asrock.com/mb/Intel/Z68%20Extre...&os=&c=

I have used the third card previously out of cross fire to confirm it works - so yes, it works 100% I am absolutely sure it works - I needed to do this as I new I wouldn't be able to put them in and pull them out when under water. Will just test though. Everything is worth a try. BRB with an update.

 

EDIT: I am now typing this with the 2x DP Port cables plugged into the third card - out of cross fire - and the primary just has the DVI cable plugged in. GPU 3 is now getting usage on MSI afterburner although now it is the only GPU working...

Edited by ugotdan

Share this post


Link to post
Share on other sites

the fact that the third slot is pci-e 4x 2.0 will hurt performance a bit but it shouldnt prevent crossfire working

 

only thing i can think of is check for any settings in the bios related to the pci-e slots although its is very unlikely its worth a look

best bet is probably to try a fresh install of windows without msi afterburner as it is possible for it to create some problems http://forums.atomicmpc.com.au/index.php?showtopic=54778

 

and just confirming you have tried with every card plugged into the first gpu or both unplugged not just disabled in software?

Share this post


Link to post
Share on other sites

the fact that the third slot is pci-e 4x 2.0 will hurt performance a bit but it shouldnt prevent crossfire working

 

only thing i can think of is check for any settings in the bios related to the pci-e slots although its is very unlikely its worth a look

best bet is probably to try a fresh install of windows without msi afterburner as it is possible for it to create some problems http://forums.atomicmpc.com.au/index.php?showtopic=54778

 

and just confirming you have tried with every card plugged into the first gpu or both unplugged not just disabled in software?

Also yes all the cards have been tested individually in the primary pci-e slot. Will gpu-z show how many lanes each pci-e slot has??

I had a look yesterday in the bios and found nothing pertains to the gpus or pci-e slots but I will have another look this afternoon just to double check.

Ref link: I've had no probs with sticky clocks.

 

I did read a post in another forum yesterday that described the exact same issue and the solution was new bridges. So new bridges in the way to rule that one out.

 

http://www.tomshardware.com/forum/332156-3...sfire-work-help

https://www.sapphireforum.com/showthread.ph...X5870-vapor-x-s

 

One funny thing with bridges is 2x crossfire will only work with two bridges connecting the two cards, but 2x crossfire is working with 1 bridge from primary to secondary and the other bridge from secondary to tertiary. The third card is recognized, it's operating fine, it's just disabled and fucking CCC is the only thing preventing the third card from being enabled!!! Gaaaarrrr!

 

There must be another program that performs a similar function as CCC? Or could there be a mod or add-on to force CCC to enable the third card?

 

I will keep searching.....

Edited by ugotdan

Share this post


Link to post
Share on other sites

So last night I ran 3mark, and then a bitcoin mining program - GUI miner, and both were utilizing all three cards, especially the miner lol 99% on all three at 56 degrees.

As I suspected, all the hardware is functioning and available, it's jut CCC that fails to give the option to enable three 3way crossfire.

Will loading up older drivers of CCC help here? Are all previous drivers included in each new release of CCC? Eg. 5-6xxx series specific drivers all currently available in the 13.4 release?

I think ill try running 12.2? Drivers and see if that helps.

Does anyone who has 3 way crossfired hd6970 cards before know which CCC driver version is best for it??

Share this post


Link to post
Share on other sites

One funny thing with bridges is 2x crossfire will only work with two bridges connecting the two cards, but 2x crossfire is working with 1 bridge from primary to secondary and the other bridge from secondary to tertiary. The third card is recognized, it's operating fine, it's just disabled and fucking CCC is the only thing preventing the third card from being enabled!!! Gaaaarrrr!

that to me suggests one of the bridges is a dud that or the bridge output on one of the cards as they only need the one Edited by Dasa

Share this post


Link to post
Share on other sites

Older drivers, and Beta drivers are always worth a shot in GPU land. They're picky as ANYTHING! the amount of drama they've caused me in the past..... grr

Especially when I try to work with 15kHz monitors.

Share this post


Link to post
Share on other sites

Yeah that's possible. I have new bridges on the way, but both the cards work in crossfire 2 way so I that tells me the bridges and bridge ports are ok... I am going to unplug all my hdd/ssd tonight and fresh install win7 on a spare to see if it'll work.

Thanks HEAPS for all the replies! I'm sure I'll manage to figure this out with all the help :) cheers

Share this post


Link to post
Share on other sites

OK after much fucking around with HDDs and OS issues and 3DMark Vantage not working and the like... I have SUCCEEDED! Turns out it was just the bridges. Clearly one was not working correctly. The new ones came in the mail today and I installed them and voila! the option to 3 way crossfire now appears in my CCC. Joy.

Thanks to all the peeps that offered suggestions on possible faults - I know it's difficult when you can't see for yourself and you have a spastic at the wheel!

Here's a pic of my first trifire benchy :p at stock settings (there was a fault somehow and the score didn't get recorded online :( but the results show underneath anyway)

Posted Image

 

 

JOY!

Edited by ugotdan

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×