Jump to content
Sign in to follow this  
Ishta2000

Audio Issues from PC to Onkyo AV receiver.

Recommended Posts

Hi all,

 

So as per the topic title I am having issues with Audio from my PC to my Onkyo AV receiver.

Currently I have the audio running from my ATI graphics card to my Onkyo receiver via a HDMI cable. Problem is when I watch movies for TV shows on my TV from my PC I don't get the surround sound. I am fairly curtain the PC is sending the signal as stereo sound even through I know the Audio is surround sound.

 

Any suggestions? Do I need to run a separate Optical cable from the PC to the receiver? Or should I just watch the movies etc by accessing the movie through the network straight from my receiver?

 

Thanks in advance for the replies.

 

Cheers

Share this post


Link to post
Share on other sites

What about if you go to Control Panel\All Control Panel Items > Sound and click once on AMD HDMI output then click on configure. Is there an option there to set up surround sound of some sort?

Share this post


Link to post
Share on other sites

Optical should be hindered compared to HDMI in terms of data transmission..... I worked in this field for a while/

 

I'd wager that your amp is set to stereo mode for that HDMI input to be honest.

Though when you throw a PC into the mix, the ammount of configuration options is huge. You'll need to make sure you're not downsampling it to Stereo, if its a legit bluray you'll want to be sure HDCP passed (though if you get a picture, it did), Hopefully you have a new enough HDMI cable; I'm not a 'blame the cable' sort of guy, but HDMI v1.0 was balls, often in quality as well as features.

 

MSY do some amazing 'Cable List' cables for $4. Solid core cables, with twin shielding and a poly weave sheath over the cable. Gold plated ends. I'm using them. They're quite amazing.

Share this post


Link to post
Share on other sites

Optical should be hindered compared to HDMI in terms of data transmission..... I worked in this field for a while/

 

I'd wager that your amp is set to stereo mode for that HDMI input to be honest.

Though when you throw a PC into the mix, the ammount of configuration options is huge. You'll need to make sure you're not downsampling it to Stereo, if its a legit bluray you'll want to be sure HDCP passed (though if you get a picture, it did), Hopefully you have a new enough HDMI cable; I'm not a 'blame the cable' sort of guy, but HDMI v1.0 was balls, often in quality as well as features.

 

MSY do some amazing 'Cable List' cables for $4. Solid core cables, with twin shielding and a poly weave sheath over the cable. Gold plated ends. I'm using them. They're quite amazing.

 

Thanks M_S. You have been a huge help over the last few days and I really appreciate your help.

 

Yeah I tired reconfiguring the receiver on the weekend but I am still having the same problem.

 

Any ideas how to double check if the HDMI input is set to stereo on the receiver?

 

Might have to rest to factory defaults again and try setting up from scratch.

 

I am using new 1.4V HDMI cables as I have a 3D TV and Bluray player too so got all the new cables about a year ago. I might actually try changing the cables and see if that helps but I don't think its the cable because the picture quality is brilliant and sound is good too but not surround.

 

I will have another go on the weekend and if I hit a wall again I post an update.

 

Cheers

Share this post


Link to post
Share on other sites

Every amp is different I'm sorry, and I never worked with Onkyo. I worked with Marantz and Pioneer; and a bunch of Anthem (god Anthem are amazing!).

 

Some oddball things to look for, are things like HDMI being set to expect a certain signal. Like, if you lock it to 'Dobly DTS' and you dont send a signal encoded in DTS, it'll ignore it. They're a pain in the ass.

 

Another possible pitfall here, is that you're not outputting digital audio from the PC.

From wiki: "Typically, an HDMI-equipped source will provide additional outputs for audio, such as line-level analog and S/PDIF, which provide a baseline audio program (such as stereo PCM)"

 

So if your PC is sending analogue\PCM down the line, thats all your amp is recieving, so its not even handling the digital that it needs. This sort of junk will be deep in configuration options for the HDMI output in the Catalyst Control Panel (most likely.)

 

If you have a DVD drive, use VLC player, and make sure all your settings are correct to output digital over hdmi, be sure to use that rare 'setup' menu on the DVD title screen and select 5.1; see if you get surround.

 

As you can tell, this is bloody tricky over the interwebs, but I can try :)

Share this post


Link to post
Share on other sites

Would still like you to check

 

Control Panel\All Control Panel Items > Sound and click once on AMD HDMI output then click on configure. Is there an option there to set up surround sound of some sort?

before going any further. No point in playing around in receivers if the PC is only outputting in stereo over the HDMI.

Share this post


Link to post
Share on other sites

Thanks guys for all the help.

 

I tried reconfiguring the PC to output the right sound type but nothing would work. So in the end I set the AV Receiver back to factory defaults and set everything up again and hey presto it worked! Some where along the way one of the setting must have change on the receiver that screwed everything else up. Not sure what or how this happened so I hope it does not happen again.

 

The main thing is I now have fantastic sound for movies and music and I am very happy.

 

Thanks again for all the help.

 

Cheers

Share this post


Link to post
Share on other sites

It would have been a setting that looked innocent, like setting it to "5.1 DTS" or something stupid, so it only liked Dolby.

Glad a factory reset worked. Considering the 'features' modern AV amps have, the software is scarily horrible.

Except Anthem, who are amazing. Did I mention how good Anthem amps are? good. lol

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×