Jump to content
Can't remember your login details? Read more... ×
Sign in to follow this  
Ishta2000

Issues with transfering files over a network.

Recommended Posts

So after setting up a new FreeNas server I have been slowly transferring all my files to the new server and I have hit a snag.

 

When I try to copy and paste my Music folder into the new Server storage its starts to think about it then Windows explorer says its not responding and eventually it just stops with no messages or errors.

 

I am completely stumped as to why this is happening because I have copied across all my movies, TV shows, photos and documents its just not copying my music across.

 

Any suggestions?

 

Ps: I even though of trying to copy the music from the current USB external storage device to my PC first then from their to the server but I cannot even copy the music to the PC drive! I have even tried to copy a few music albums as a test and the same problem occurs.

Share this post


Link to post
Share on other sites

Some media service might still be hanging on to the files and folders. EG Windows media centre may still be indexing them in the background.

Start by first going to the music files via the proper drive path, not the Libraries option. EG

C:\Users\Ishta\Music

If still problems try killing any media servers you have running and try again.

Or sometimes when I have weird issues copying to my server I find remoting in to the server with Remote Desktop and then copying from the PC shares to the server works.

Share this post


Link to post
Share on other sites

protip: Turn on FTP, and send them that way.

Its about twice as fast as a windows\samba file share, and it wont hang if you're doing millions of files it once.

 

FileZilla will handle it no problems :)

Actually, even windows explorer might? Its been YEARS since I tried, but you used to be able to type ftp://192.168.1.99 or whatever that server was; into windows explorer, and have it open an 'ftp window'.

 

If you don't want to do this, try mapping the shared folder as a network drive. Its weird, but windows seems to try.... longer.... to copy drive -> drive, than local->file share. Im sure there's a reason, I just don't know it :P

 

but seriously, FTP, its SO much faster.

Edited by Master_Scythe

Share this post


Link to post
Share on other sites

protip: Turn on FTP, and send them that way.

Its about twice as fast as a windows\samba file share, and it wont hang if you're doing millions of files it once.

 

FileZilla will handle it no problems :)

Actually, even windows explorer might? Its been YEARS since I tried, but you used to be able to type ftp://192.168.1.99 or whatever that server was; into windows explorer, and have it open an 'ftp window'.

 

If you don't want to do this, try mapping the shared folder as a network drive. Its weird, but windows seems to try.... longer.... to copy drive -> drive, than local->file share. Im sure there's a reason, I just don't know it :P

 

but seriously, FTP, its SO much faster.

 

Thanks MS I will give FTP a go. Never used it before so its all a new learning experience or me.

 

Cheers

Share this post


Link to post
Share on other sites

heh, really?

Its the preferred way, even today, to download files from the internet too. Its usually HEAPS faster.

 

I'm going to assume FTP is another 'tool' that comes with FreeNAS these days, its very common. If not it'll be easy to setup.

 

and for your windows box, FileZilla.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×