Jump to content
Sign in to follow this  
NukeJockey

Using multiple internet connections on 1 device

Recommended Posts

I work from home and as part of my work, I access a company website, to access this website I need a whitelisted IP, originally I was with internode so I could have a static IP address set and there were no issues. But then I swapped ISPs and cannot get a Static IP through iinet. Because of the Dynamic IP address, its not possible to whitelist an IP address from me as it always changes, so I was given an iinet 3G connection which uses a static IP address. However, this connection is slow and has limited quota (5gb per month) so I don't want to use it for general web browsing.

 

I guess my question is, if I have 2 network connections, both with the internet, is there something I can do to choose which program uses which connection? Preferably, would love to have my proper network connection for everything else and then just have a web browser connecting to the net via the 3g stick for the one website I need it for. Anyone know if this is possible?

Share this post


Link to post
Share on other sites

Is one cabled and one wifi?

And is the app web-based?

 

If both are yes (or you can get two wifi cards), then you'd dedicate a specific browser.

 

as an example:

 

Ethernet: 192.168.1.1

Wireless: 10.0.0.1

 

Firefox gateway: 192.168.1.1

IE Gateway (: 10.0.0.1

 

So therefore, everything that goes through IE will go through wifi (thusly static) and everything through firefox will be 'fast'.

 

I used to do this in school using a phone, and the school internet. I simply used the IP of the modem in the 'proxy Settings' area. TECHNICALLY this description is incorrect... so who knows if it still works.

 

also;

http://windows.microsoft.com/en-au/windows...s#1TC=windows-7

Share this post


Link to post
Share on other sites

Is one cabled and one wifi?

And is the app web-based?

 

If both are yes (or you can get two wifi cards), then you'd dedicate a specific browser.

 

as an example:

 

Ethernet: 192.168.1.1

Wireless: 10.0.0.1

 

Firefox gateway: 192.168.1.1

IE Gateway (: 10.0.0.1

 

So therefore, everything that goes through IE will go through wifi (thusly static) and everything through firefox will be 'fast'.

 

I used to do this in school using a phone, and the school internet. I simply used the IP of the modem in the 'proxy Settings' area. TECHNICALLY this description is incorrect... so who knows if it still works.

 

also;

http://windows.microsoft.com/en-au/windows...s#1TC=windows-7

Thanks M_S, I'll give that a go. Was also linked to this by a friend, am yet to try it though.

 

*EDIT* How would I go about finding the internal ip of my 3g stick on windows 7?

Edited by NukeJockey

Share this post


Link to post
Share on other sites

does it not show up as an additional network card?

 

If so, an 'ipconfig /all' in cmd should show it. Hope this old trick works for ya :)

If not that force bind looks awesome!

 

 

 

If for some reason all fails, disable the 'other' connection, and do a 'tracert www.google.com' first\second hop should be internal

Share this post


Link to post
Share on other sites

does it not show up as an additional network card?

 

If so, an 'ipconfig /all' in cmd should show it. Hope this old trick works for ya :)

If not that force bind looks awesome!

 

 

 

If for some reason all fails, disable the 'other' connection, and do a 'tracert www.google.com' first\second hop should be internal

 

ipconfig showed the internal ip, added it to the proxy setting in chrome, but it said it could not connect to the proxy server, so I'm not sure whats going on. I'll have a fiddle another time.

Share this post


Link to post
Share on other sites

does it not show up as an additional network card?

 

If so, an 'ipconfig /all' in cmd should show it. Hope this old trick works for ya :)

If not that force bind looks awesome!

 

 

 

If for some reason all fails, disable the 'other' connection, and do a 'tracert www.google.com' first\second hop should be internal

 

ipconfig showed the internal ip, added it to the proxy setting in chrome, but it said it could not connect to the proxy server, so I'm not sure whats going on. I'll have a fiddle another time.

 

Its because technically its not a proxy server, its a gateway. It was an old trick worth trying.

Did that forcebind IP thing work? that looks perfect.

 

You should have 2 very different internal IPs one will be your 'usual' and one will be your 3G.

 

HOPEFULLY the 2 DHCP servers (from your usual router, and your 3G) are on very different ranges (192.168~~ and 10.0.~)

If its a USB stick though, not a 'MiFi' style device, it might be using some funky software and being seen as a 'modem' as opposed to a network card. In which case, I'd need to see it to help much further; not something ive tried.....

 

IF that was the case, I'd put the SIM into an old phone and turn on 'hotspot'. So that I have a new IP address for that forcebind trick to work ;)

Edited by Master_Scythe

Share this post


Link to post
Share on other sites

But then I swapped ISPs and cannot get a Static IP through iinet.

http://www.iinet.net.au/business/small/internet/nbn/

 

 

http://www.iinet.net.au/business/medium/internet/broadband/

 

All our business bundles include these neat extras:

 

Anytime Quota

We don't count uploads

1GB of included webspace

 

20 included mailboxes

Static IP address

 

Unfortunately if I go on a business plan I can't get my FetchTV bundle, I'm well aware that their business plans have static IPs, but when I was with internode, I could pay an extra $10 a month to get those features, I don't understand why iinet can't offer them on home plans. (Spoke to them on the phone about this and they were happy to upgrade me to a small business plan, but I was looking at $150+ a month for the connection and the fetchTV)

 

does it not show up as an additional network card?

 

If so, an 'ipconfig /all' in cmd should show it. Hope this old trick works for ya :)

If not that force bind looks awesome!

 

 

 

If for some reason all fails, disable the 'other' connection, and do a 'tracert www.google.com' first\second hop should be internal

 

ipconfig showed the internal ip, added it to the proxy setting in chrome, but it said it could not connect to the proxy server, so I'm not sure whats going on. I'll have a fiddle another time.

 

Its because technically its not a proxy server, its a gateway. It was an old trick worth trying.

Did that forcebind IP thing work? that looks perfect.

 

You should have 2 very different internal IPs one will be your 'usual' and one will be your 3G.

 

HOPEFULLY the 2 DHCP servers (from your usual router, and your 3G) are on very different ranges (192.168~~ and 10.0.~)

If its a USB stick though, not a 'MiFi' style device, it might be using some funky software and being seen as a 'modem' as opposed to a network card. In which case, I'd need to see it to help much further; not something ive tried.....

 

IF that was the case, I'd put the SIM into an old phone and turn on 'hotspot'. So that I have a new IP address for that forcebind trick to work ;)

 

Haven't looked into it much since posting this tbh, have just been using the 3g stick as the main connection. Doesn't seem to be using too much data during the work day.

 

Thanks for all the info though, I have a few things to try now.

Edited by NukeJockey

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×