Jump to content
Sign in to follow this  
fajw

wireless LAN Internet problem

Recommended Posts

This PC was connecting (wirelessly) fine before to the LAN and the Internet when it was running Windows XP. I updated to Windows Vista and it doesn't connect to the Internet how it was doing so before, but it connects fine through my phone and through the old way through the (Netgear) router if security is disabled. Wireless PC hardware is atheros. Latest drivers from the Acer website are installed. I have tried the button method to connect to the LAN and the password method and I have tried various security settings.

 

Any ideas?

 

Thanks.

Share this post


Link to post
Share on other sites

Better off doing it manually. ie, connect to the router via a cable to do the initial config - setup the security, SSID name, password etc.

 

Probably easier to do initial testing with a phone or tablet connecting wirelessly, once it's verified as good, setup the wireless access on the PC.

 

How it's done... varies depending on what interface is used. There's generally a built in WiFi control panel with Windows and it's possible to have a vendor's one installed along with the driver that overrides that.

 

If you keep having trouble, maybe try initially with an open Wifi config then up the security once you can establish a connection.

Share this post


Link to post
Share on other sites

Thanks for the reply.

 

Sorry; I didn't explain well. It says it connects to the WLAN but it doesn't connect to the Internet.

 

I'm considering updating the router's firmware.

Edited by fajw

Share this post


Link to post
Share on other sites

Thanks for the reply.

 

Sorry; I didn't explain well. It says it connects to the WLAN but it doesn't connect to the Internet.

 

I'm considering updating the router's firmware.

Then you have a config issue on either the PC or router if you are actually connected to the WLAN.

On the PC check IP, gateway and dns server settings. Make sure all are set to automatically receive.

Check browser settings and make sure you have not got some sort of proxy set.

On the router check you are not MAC blocking the wireless card or similar.

Share this post


Link to post
Share on other sites

The browser worked fine when I disabled security on the router and when I used my phone so I don't think it is a browser issue and I don't think it is an IP address issue or a DNS issue. I will check the MAC blocking thing although I think it is unlikely to be that unless when I changed the security setting (eg. WPA2) it also changed to allow all MAC addresses.

 

Thanks.

Share this post


Link to post
Share on other sites

Like I said: it worked when I got rid of the security. I don't see why the DNS and gateway IP addresses would change with the security.

Share this post


Link to post
Share on other sites

Like I said: it worked when I got rid of the security. I don't see why the DNS and gateway IP addresses would change with the security.

What security? Be more specific.

Share this post


Link to post
Share on other sites

Sorry; I mean like WPA2 for example. Maybe I should have said "encryption".

Share this post


Link to post
Share on other sites

Does that laptops chipset support the type of encryption you're using?

 

If you're using WPA2; try the other type (TKIP\AES).

 

If you're not somewhere thats frequented by 'hackers' WPA-1 might be enough. It still takes ages to even POSSIBLY break through it.

Share this post


Link to post
Share on other sites

Ensure the network card/dongle on the PC supports WPA2. Ensure the entry method is the same, e.g. Ascii or Hex. Make sure you replicate the capitalization on both sides. There might also be encryption types and other options that you'd want to replicate on both sides.

 

I let my modem use simple WEP for years... not really advisable, supposedly it can be cracked by even portable apps in about a minute.

Share this post


Link to post
Share on other sites

Ended up going with WEP. I blame Windows Vista.

Share this post


Link to post
Share on other sites

Ended up going with WEP. I blame Windows Vista.

Hope you don't live near anyone or on a public road because, as 'bags said WEP can be broken in very short order.

Share this post


Link to post
Share on other sites

If the antenna strength is controllable, you can decrease it to shorten the effective range. I didn't worry too much with mine as I usually turned it down with the previous modem, so outside range was maybe 5-6 metres.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×