Jump to content
Sign in to follow this  
Nich...

Dodgy psu = new midrange build time

Recommended Posts

RAM is all at the default XMP settings, yeah.

 

Backing up some stuff to do while the desktop is offline. I paid for the bootable memtest option earlier, so just need to find a free USB key and then do t hat.

Share this post


Link to post
Share on other sites

hci confirms there is a stability problem somewhere

but you really need to run the linux test on each stick to see if its faulty ram or if hci spat out that error due to something else

should only need to run it for an hour each stick

1 hour seems optimistic?

 

20% coverage of a single 8GB stick has taken about half an hour.

Share this post


Link to post
Share on other sites

You might find it's like memtest, the % complete is percentage of total tests completed. As opposed to number of full passes using a single algorithm.

Share this post


Link to post
Share on other sites

 

Google stressapp test via Linux Mint (or another compatible Linux disti) is the best memory

stress test available. Google use this stress test to evaluate memory stability of their servers

– nothing more needs to be said about how valid that makes this as a stress test tool.

 

  • Like 1

Share this post


Link to post
Share on other sites

Errorsssssss

 

Trying to work out why the stressapptest is not running.

 

mint@mint ~ $ stressapptest -W -s 3600
Log: Commandline - stressapptest -W -s 3600
Stats: SAT revision 1.0.6_autoconf, 64 bit binary
Log: buildd @ kapok on Wed Jan 21 17:09:35 UTC 2015 from open source release
Log: 1 nodes, 4 cpus.
Log: Defaulting to 4 copy threads
Log: Total 7931 MB. Free 4878 MB. Hugepages 0 MB. Targeting 7343 MB (92%)
Log: Prefer plain malloc memory allocation.
Process Error: memalign returned 0
Process Error: failed to allocate memory
Process Error: Sat::Initialize() failed

Status: FAIL - test encountered procedural errors

Process Error: Fatal issue encountered. See above logs for details.

Share this post


Link to post
Share on other sites

hmm bugger im no linux user it just worked for me

found another with the same problem fairly recently maybe its a compatibility problem with a new linux update

Share this post


Link to post
Share on other sites

I found very few hits when googling, I'm not sure if it's an issue with the distro, how it's decided to act on my specific hardware, or what.

 

Also a linux noob, so beyond trying to sudo the program, and googling and finding nothing useful, I gave up : \

 

Guess I'll try memtest overnight again and see if the stick I left in is the culprit.

 

Found an SSD (Samsung 850 EVO 250GB), some RAM (Corsair Vengeance Pro 2400c11) at MSY. Assuming I can find a nearby store with them in stock, I guess I'm going for a drive tomorrow and just hoping after all of this it's not mobo/CPU related. All I probably need now is an external HSF to replace the Intel one - pointless getting faster ram if I don't actually OC >>

Share this post


Link to post
Share on other sites

 

 

Mon Jan 16 18:17:21 2017 >> Memory error detected between 0xef94d3ac, 0x42f6d3ac difference = 8000000

 

Guess it's time to try the other stick.

Share this post


Link to post
Share on other sites

Am I right in seeing there's a potential issue with RAM slots, between the NH15D, and the ASrock Z97m pro4, Asus GTX970, and Corsair Vengeance Pro RAM?

 

Seeing maybe potential issues with the headers on the RAM, but not sure if that's an issue if I just don't use the nearest slot to the CPU socket o.0

 

Going to try seeing if I can do a motherboard swap between this case, and my old P180, to give more space for drives around the video card -_-

 

(So far I've found an error in the single DIMM. So... assuming it's a memory issue, and not mobo/CPU/IMC?)

Edited by Nich...

Share this post


Link to post
Share on other sites

if the single error is consistent to that stick only with ether stick in the same slot its safe to say its the ram

 

ok i asked about the error you got and it was suggested that the test was trying to run on more ram that what was available on auto

you can manually set the amount of ram to test so maybe try this and see if it runs

if that allows it to run adust the amount to suit

stressapptest -W -M 256 -s 3600

Share this post


Link to post
Share on other sites

Yeah that seems to have done it. Thanks!


For anyone else reading along at home, with the mint live image, open the Mint menu in the bottom left, along the left hand edge select 'Software Manager', and search for stressapptest and you can install it from that.

Share this post


Link to post
Share on other sites

Neat! thanks :)

 

Vengance RAM doesn't have LED's does it? Because Ive seen a very repeatable trend in requiring a SIGNIFICANT voltage bump (outside spec) if the ram has LEDs on it.

Share this post


Link to post
Share on other sites

4 hours overnight and the 'good' stick came up with no errors in stressapptest.

 

Will give the 'bad' stick an hour in the same socket just to be sure, and maybe in one other socket just-in-case.

Share this post


Link to post
Share on other sites

just double checking that you did change the -m 256 to a number more suitable for your quantity of ram

Share this post


Link to post
Share on other sites

Is the memory specified a fixed pool, or it's a moving window that checks all available ram?

Share this post


Link to post
Share on other sites

not sure

but if you specify a bit more ram than you have i know hci memtest starts using the hdd <not good

and the linux test just refused to start for you when it thought you had 8g

not sure how much linux uses but im guessing you want ~3-5% free space left with linux and gsat running

provided you have the ram over 90% full and the hdd isnt being flogged for that test last night id say close enough

Edited by Dasa

Share this post


Link to post
Share on other sites

In windows I just looked at task manager and as long as my paging disks weren't being hit, I knew I was hitting enough RAM. In Mint? NFI how to easily check that :

Oh right, sudo apt install sysinfo, and it shows how much free memory of the total there is. Lowball that slightly, and it's working. 6000 out of 7931 MB is not super ideal but meh.


For whatever reason, Mint is doing software rendering and doesn't seem to like my video drivers properly, so I wonder if that's causing the issue, if that's not normal.

Share this post


Link to post
Share on other sites

yeah i was never able to install drivers seemed to do its job without them no idea if its software rendering though or just auto installed some

gave it a run on auto its 7927mb total 7084mb free target 7339mb

Edited by Dasa

Share this post


Link to post
Share on other sites

ok im leaning towards thinking its not the ram

if its cache\memory controller related one of these may improve stability try increasing these to there max recommended for 24\7n use and run hci again tonight


CPU Cache Voltage
Select “Override Mode” to adjust the CPU cache voltage. This is the cache/ring voltage of your CPU. Increase this voltage if you want to achieve higher core clocks. Usually more than 1,15 Volt is not recommended for daily use.

System Agent Voltage Offset
This voltage is important to run high memory clocks. Stock is 0.85 Volt and usually you don’t need more than 1.00 Volt (+0.15 Volt) for 24/7 systems.

CPU Digital IO Voltage Offset
This voltage also helps for memory overclocking. Stock voltage is about 1.0 Volt. More than 1.15 Volt (+0.15 Volt) is not recommended for daily use.

CPU Analog IO Voltage Offset
This voltage also helps for memory overclocking. Stock voltage is about 1.0 Volt. More than 1.15 Volt (+ 0.15 Volt) is not recommended for daily use.

 

 

i doubt these two will help but you can try up them to if you want provided your cooling is adequate

CPU Vcore Voltage Mode
Select “Override Mode” to adjust the CPU voltage. This is the core voltage of your CPU. Increase this voltage if you want to achieve higher core clocks. Usually more than 1,35 Volt is not recommended for daily use.

DRAM Voltage
The DRAM Voltage is the Voltage of your memory. Check the memory modules for the specified voltage. Most are between 1.35 and 1.5 Volt. The official limit according to Intel is 1.5 Volt, however 1.65 Volt modules are no problem at all according to my testing.

 

Edited by Dasa

Share this post


Link to post
Share on other sites

haha, managed to get it to run with -M 6600.

 

Except it then hung the system, so... Hmm.

Edited by Nich...

Share this post


Link to post
Share on other sites

In the OC Tweaker/FIVR section of the UEFI/BIOS:

 

FIVR Switch Frequency Signature: Auto

FIVR Switch Frequency Offset: Auto

 

CPU Vcore Voltate Mode: Override

 

Vcore Override Voltage: 1.35 (max 2, min 0.8)

 

VCore Voltage additional offset: Auto

Vcore Adaptive Voltage: Auto

Vcore Voltage Additional Offset: Auto

 

CPU cache voltage mode: Override (was set to auto, wondering about maybe trying Adaptive after this)

 

CPU cache override voltage: 1.15 (max 2, min 0.8)

 

CPU Cache voltage offset: Auto (max 1, min -1)

 

System Agent Voltage Offset: 1.00 (max 1, min -1)

 

CPU Digital and Analogue IO Voltage Offsets: 1.00 (max 1, min -1)

 

CPU Integrated VR Faults: Auto (auto/enable/disable)

CPU Integrated VR Efficiency Mode: Auto (auto/enable/disable)

 

 

 

From lower down a bit, for info's sake:

 

Power saving mode: Disabled

CPU Input Voltage: Auto

 

DRAM voltage: 1.650 (was 1.585)

 

PCH 1.05V: 1.082

PCH 1.5V: 1.506

 

 

 

Hmmm, it didn't like that.

 

Setting DRAM and CPU Vcore back to what they were

 

 

 

....also doesn't like that and doesn't want to boot. Hmm.

 

 

 

...Back to defaults and it boots ok.

 

Trying out Adaptive Mode for CPU Cache Voltage Mode. It boots, at least.

Share this post


Link to post
Share on other sites

I have been told to jump on this thread ,maybe i can get help from you guys please,If im hijacking sorry just need help.

 

When i boot up i get 3 beeps after a series of 3 to 10 sets of 3 beeps the pc boots to windows start page.

Ive replaced the 3v battery

Ive taken out one of the Ram sticks Gskill Ripjaw F3-14900CL 9D -8GBXL MOBO is z77 exteme 4 ,i am only using onboard GPU as my card died ,If i add the other stick to the slot 3 it wont boot just starts beeps 3 times then restarts .

I have been able to set the XMP Profile to 1866

I have also tired the sticks in 2 and 4 slots still no joy

Share this post


Link to post
Share on other sites

Did you follow any of the advice in this thread? That's what you were told to do, not post your problem in here as well as in it's own thread.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×