Jump to content

Corrupt 2002 MDB file

Recommended Posts

I have an access 2002 database that will open but will not compact. I tried to create a new mdb and import the objects but I get the message that the db is corrupt. Any ideas would be greatly appreciated!



Share this post

Link to post
Share on other sites

Try this sequence in order below or as an additional resources for restoring .mdb file see and learn following topics, and in case your corruption is severe, one more solution must assist you




https://www.repairtoolbox.com/accessrepair.html Access Repair Toolbox


  1. Backup.
    Make a backup copy of the bad database, without overwriting any existing backups. Whatever has gone wrong, you don't want to make it worse, and a backup gives you multiple attempts at recovery.
  2. Uncheck the Name AutoCorrect boxes.
    In Access 2007: Office Button | Access Options | Current Database.
    In previous versions: Tools | Options | General.
  3. Compact.
    In Access 2010: Compact and Repair Database on the Database Tools ribbon.
    In Access 2007: Office Button | Manage | Compact/Repair.
    In previous versions: Tools | Database Utilities | Compact/Repair.
  4. Decompile.
    Close Access, and enter something like this at the command prompt:
    "c:\Program Files\Microsoft office\office\msaccess.exe" /decompile "c:\MyPath\MyDatabase.mdb"
    Use the path to where msaccess.exe is found on your computer, and include the quotes.
  5. Compact again.
    Open Access (holding down the Shift key if you have any startup code), and compact again.
    Do this twice: one compact does not work in all versions (unless you close Access between step 4 and 5.)
  6. Set minimal references.
    Open a code window.
    Choose References from the Tools menu.
    Uncheck any references you do not need.
    For a list of the ones you typically need in your version of Access
  7. Compile.
    Still in the code window, choose Compile from the Debug menu.
    Fix any errors, and repeat until the code compiles okay.
  8. Set code options.
    Still in the code window, choose Options on the Tools menu.
    On the General tab, make sure Error Trapping is set to "Break on Unhandled Errors", and Compile On Demand is unchecked.

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now