Jump to content
Trigger_Troy

DisplayPort Issues - GTX680FTW+ - 28" UE850 4k Display

Recommended Posts

Afternoon team,

 

I've been on atomic for many, many years. I've lapsed over the last few years however and thought I'd come back fresh... with a problem of course.

 

Current System:

Windows 10
Z77 Sabertooth

EVGA GTX680 FTW+ 4Gig

16Gig Ram

Few years old, still holding up ok

 

 

What I know:

- GTX680 cards can output to 4k

- I can get 4k output via HDMI at 30hz - which is barely usable (3840x2160)

- Displayport should work perfectly, however is restricted to 2560x1440 at the moment - I should have access to 3840x2160

 

What I've tried:

- Monitor drivers

- nVidia drivers (clean installs, old versions etc)

- Motherboard BIOS Update
**EDIT I've also tried the OSD for the DP v 1.1 / 1.2 settings - this screen doesn't seem to be MTP and has 1.2 set by default
**Attempted to force it with CRU - no luck forcing 3840x2160 - CRU recognizes this as a resolution is should support

 

Question

 

I've seen a lot of people with these issues, however they seem to usually be rich dudes with 4 displays.. I am most definitely not one of them. I wanted a display that would see me though another 10 years much like my BenQ 24" has done before this.

 

displayport.org says that all displayport cables are born equal and swapping this one out for another cable shouldn't have any impact.. however this will be the first thing i try.

 

*The monitor came with a mini display port to normal size cable, which I couldn't use.. i then proceeded to purchase a normal DP to DP from Msy in north melbourne.
*It was $6 (I think this may be the cause.. but according to displayport.org they would have me believe a cheapy may have issues, but this wouldn't be one of the issues)

 

Can anyone confirm that is could be the cable and is there any other troubleshooting I can perform? I'm seriously stuck.. if i can't fix it tomorrow this monitor has to go back.. i can't drop $650 on a monitor that doesn't output at a res that should be supported no issues.

 

I have no idea how to look for logs or interogate the displayport on the graphics card for more info.

 

BIOS is 80.04.28.00.80
Driver 10.18.13.6143 WHQL (ForceWare 361.43) / Win 10 64
Bus interface PCI-E 3.0 x 16 @ 16 3.0

GPU GK104

http://www.techpowerup.com/gpudb/b153/evga-gtx-680-ftw.html

 

 

Any info at all will be greatly appreciated

 

**Edit**

 

I've also tried the OSD for the DP v 1.1 / 1.2 settings - this screen doesn't seem to be MTP and has 1.2 set by default

Edited by Trigger_Troy

Share this post


Link to post
Share on other sites

Check specs of both monitor and card for limitations e.g. what refresh rates for that resolution can be had, and whether running multiple monitors reduces what modes the cards can do.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×