Jump to content
scruffy1

networking noob

Recommended Posts

below is a (simplified) version of my home network

the smart tv and the htpc can both see the interweb

my desktop can see the smart tv, but no longer the htpc

neither the htpc or the smart tv can see the server


the gateway and the router are transparent to the interweb, but the other home network things (server / home group) are not connected

the same eop connection allowed the whole network to be seen from the htpc until the router split the line

 

house%20network_zpsud71ia2n.jpg

 

from my cursory knowledge, the tv has an ip address on the gateway network, but can't see it

 

the htpc won't even show up on the network, and i presume it hasn't been assigned an address... can i force one ?

i'd prefer not to, as i usually let the gateway assign dynamic addresses and can live without the complication

 

 

last info : the secondary router is a cheap arse tenda r502, and it connected upstream to the web without configuration

is it possible that this is merely an interweb "receiver" and can't grok the local network ?

 

thanks for any help

 

Share this post


Link to post
Share on other sites

Hmm... I think with a second router you've created another distinct LAN and won't see devices up a level which have been assigned addresses on the first LAN.

 

Not sure... can you configure such that IPs are handed out only by the outermost router?

 

As for fixed IPs of devices hanging off my wireless LAN, I use it, very handy. That means I can just put a phone or tablet on WiFi, start the FTP client then just select a Favourite in an Explorer file window and drop files there knowing it'll go to the device I want.

Re the smart TV, are you using DLNA or some other sort of uPnP server to play videos from local sources?

Share this post


Link to post
Share on other sites

Considering it's quick and a 'once off' to assign IP addresses, I'd do it.

 

First confirm you MODEM\ROUTER is 192.168.1.xxx (if it's not, then just follow its code, eg. 10.0.0.1)

You can leave DHCP on for anyone or anyhting else that plugs\wifi's in.

Just start at 192.168.1.200 (or 10.0.0.200, or whatever matches the range of your modem), and work your way up because its unlikely to ever see 200 dynamically assigned computers :P you wont get conflicts that way.\

 

Just for more info, your subnet mask should be 225.225.225.0 (possibly 225.225.0.0 if your IP is 10.0.0.1, bloody optus gear).

 

 

If you NEED to put a gateway in, point it to your modem\router too (likely 192.168.1.1) since it's the guy in charge of IP resolution.

 

 

If you STILL can't see your shares, you might want to consider disabling simple file sharing and doing it the odl fashioned way

http://helpdeskgeek.com/how-to/what-is-simple-file-sharing-and-how-to-turn-it-off/

 

When it comes to permissions, add 'EVERYONE' to the list, and give them 'READ' permissions. Assuming there's no private data and you're happy for everyone to see the server share in question.

Share this post


Link to post
Share on other sites

firstly, yes, there is "new" network on the tenda

 

i have discovered the interface, and it assigns :

 

wan ip of the tenda is 192.168.1.3

lan ip is 192.168.0.1

 

the main network is on the gateway at 192.168.1.254

the server is on 192.168.1.1

 

but the htpc is on 192.168.0.2 - so not in the "acceptable" address range of 192.168.1.1 >>> 192.168.1.50 as assigned


help me obi wan !


lots of available settings on the tenda to do stuff, but less knowledge here of what will fix the communications

Share this post


Link to post
Share on other sites

You can usually set what range of addresses a router assigns, and the IP of the router itself.

If you have two, then it's probably a really good idea to set one of them to use the popular alternate which is 10.1.1.1. That'll help avoid some of the confusion when working out who's bitch each device is.

Share this post


Link to post
Share on other sites

Ok what you have done is double NAT your network and the Tenda router is interfering.

What you need to do is configure the Tenda in AP or WAN bypass mode.

 

Right had a look at the manual and can't see anything about an AP mode so we will have to do this manually.

OK on the main router set the DHCP range to something less than the (probably) full range. EG set DHCP to 192.168.1.1 to 192.168.1.100 (if 99 IP addresses are not enough then you have other problems).

 

Now log in to the Tenda and set it's LAN IP to 192.168.1.101, disable it's inbuilt DHCP server, save all changes and reboot it.

Whilst it is rebooting plug an Ethernet lead between the EoP device and LAN1, LAN2, LAN3 or LAN4 of the Tenda. You do not use the WAN port at all.

With this setup all the Tendas NAT and DHCP functions should be bypassed and the Tenda is basically acting as a dumb switch.

/edit

If you want to log in to the Tenda again it's IP will now be 192.168.1.101

 

Personally as the Tenda does not have wireless I would chuck it in the bin and get a gigabit switch. An 8 port will only set you back about $30.00, and a 5 port about $20.00

https://www.pccasegear.com/products/11562/tp-link-sg1005d-5-port-unmanaged-gigabit-desktop-switch

https://www.pccasegear.com/products/2772/tp-link-sg1008d-8-port-gigabit-desktop-switch

Edited by aliali

Share this post


Link to post
Share on other sites

thanks aliali, i'll give it a go

 

i don't need wireless, as the gateway has 2.4, but even that is redundant as i am using a unifi wap independently off the gateway, which is fine for my little house

 

the eop to the lounge is just for the streaming of "big" files which reception / 2.4 congestion struggles to move effectively fast

 

 

 

the tenda is a piece of ancient kit my spouse bought me years ago, and i never used it before... but now there was need for a single eop to share to the htpc and tv even though i could have left well enough alone

 

 

tldr : that worked ! the old switcheroo, eh ?

 

if you need gratuitous medical advice you now have a consultation whenever you might feel it's needed :)

 

edit : thanks also to rybags; you get a smiley stamp :)

Edited by scruffy1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×