Jump to content
Forum upgrade is live! Read more... ×
Sign in to follow this  
Director

Windows 8 HDD at 100% usage?

Recommended Posts

Headscratching time.

 

Have disabled the usual culprits, superfetch, indexing and search, have tried a new HDD ( cloned).

 

Running Windows 8 with only 2gb ram (that might be it?)

 

Drivers are up to date etc. No viruses.

 

The PV is slow as a turtle because of it.

 

Any ideas?

 

Cheers

Share this post


Link to post
Share on other sites

Strange. Was going to suggest Windows Update too but you'd not really expect HDD usage to be much even if it was DLing multiple Gigs worth of stuff.

Maybe try having the machine off-net for a while to see if it comes to a stop.

Check Event Logs etc to see if anything's complaining.

 

Ensure no junk indexing software's installed like Nero Scout, or media server type stuff which will often maintain it's own index.

Share this post


Link to post
Share on other sites

Can't see anything like that on there.

 

Have unplugged from the net but made no difference. Must add that it's also using most of it's ram too (all 2gb of it :) ) constantly.

Share this post


Link to post
Share on other sites

But what's using it?

 

If it's constantly accessing the HDD then a fair chance it's just caching the reads which could bloat reported Ram usage.

Share this post


Link to post
Share on other sites

Maybe HDD not properly detected. Check BIOS or UEFI for HDD Settings.

 

Kinda sounds like this happening as years ago i had that problem when you plugged in HDD you knocked out the Auto settings.

Share this post


Link to post
Share on other sites

But what's using it?

 

If it's constantly accessing the HDD then a fair chance it's just caching the reads which could bloat reported Ram usage.

Can't see much actually, the resource monitor shows the HDD at about 1.7mps (or thereabouts) yet 100% usage?

Just putting on 8.1 now so I'll see if that does anything for me.

Maybe HDD not properly detected. Check BIOS or UEFI for HDD Settings.

 

Kinda sounds like this happening as years ago i had that problem when you plugged in HDD you knocked out the Auto settings.

Everything says AHCI as far as I can see.

Share this post


Link to post
Share on other sites

you'll find its a failing drive.

 

look in the prformance tab and sort by HDD usage.

 

You'll find its like "5MBPS" or something total use, which is then showing 100%.

 

I couldn't solve it either and resolved it must be hardware because i see it more often on old systems that scan clean.

  • Like 1

Share this post


Link to post
Share on other sites

I tried a different drive before posting and it didn't fix it. :)

 

I installed 8.1 last night and it was still thrashing so I left it d/ling 100 or so updates when I went to bed, got up this morning and it's al good. Memory is at 52% and disk is at 0% when idle but jumps up when I do something (which is normal) then drops back down again. So all is good, will restart and see what happens.

 

OK restarted and it's back to high memory-HDD use 99% so if I had to guess I'd say it a memory intensive windows process that is cause the swap file to be flogged because of the low RAM amount? At a guess. Will leave it and see how long it takes to settle. Will try some extra ram when it turns up as well.

 

Removed HP support assistant and that reduced the thrashing down to about 5 minutes. :)

Edited by Director

Share this post


Link to post
Share on other sites

If you've disabled caching like superfetch, turned off indexing, etc, then I'd suggest what MS said: disable the page file entirely so it can't swap to disk. Don't be surprised if it BSODs when it runs out of RAM in that scenario, but it should at least test it.

 

Other option is to try a fresh install rather than an OEM version. I think 8.1 images are still available if you don't want to try a win10 update/format/fresh install dance.

Share this post


Link to post
Share on other sites

Not using AVG by any chance are you? AVG totally thrashes HDDS when doing scans. It's one of the reasons I stopped using it, it is far far to much of a resource hog.

Share this post


Link to post
Share on other sites

2GB

 

Sounds like you might want some more. Win10 has a hell of a time with 6GB, if I have too many tabs + a few other things open.

Share this post


Link to post
Share on other sites

2GB

 

Sounds like you might want some more. Win10 has a hell of a time with 6GB, if I have too many tabs + a few other things open.

 

That's strange.

With modern memory managment, 2GB in windows 10 I found to be actually rather snappy.

Well, snappy compared to running 2GB with windows XP for example.

 

You'd be surprised how little ram you can get away with, with a large swap file and a modern SSD.

Share this post


Link to post
Share on other sites

Well, yes, but the point i was un-clearly trying to make, is modern memory management is amazing.

Windows XP with the same SSD would be balls compared to 10 with the above config.

That's all.

Share this post


Link to post
Share on other sites

Of course it would.

 

Windows XP is a dinosaur of an operating system and has no place on a modern computer.

 

Blocking I/O operations, no privilege separation, display drivers run in kernel ring, blah. Kill it with fire.

Share this post


Link to post
Share on other sites

I'd leave AHCI as is, it's possible to break the OS by changing it though Win7/later would probably do the driver change OK.

AHCI is supposedly a necessity for SSDs so that the Trim function works, not to mention NCQ for all supporting devices.

Share this post


Link to post
Share on other sites

 

 

Everything says AHCI as far as I can see.

 

Turn AHCI off and put it back to SATA see if that helps ,or whatever it is.

 

 

AHCI is SATA mode

Edited by Jeruselem

Share this post


Link to post
Share on other sites

Not exactly... Sata in itself is the physical interface. AHCI describes the extended command set available as compared to basic Sata which uses IDE emulation.

 

AHCI in itelf wasn't even properly supported by Intel chipsets until something like 2008, and it's an evolving standard with ongoing revisions and additions (as is Sata itself).

Share this post


Link to post
Share on other sites

 

Have disabled the usual culprits, superfetch, indexing and search, have tried a new HDD ( cloned).

 

 

I thought it was a HDD ,not a SSD?

Edited by codecreeper

Share this post


Link to post
Share on other sites

The "culprits" are still applicable regardless of which you install the OS onto.

 

Guess should have asked early on how big the Paging file is... in theory if it was a ridiculously small amount of total virtual memory it could cause weird behaviour.

 

Though all said... I've got a 1 Gig Ram tablet that runs Windows 8 and it seems to handle it just fine though I've not really tried heavy stress testing on it, original Half Life is about the hardest job I've assigned to it besides video encoding.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×