Jump to content
Sign in to follow this  
g__day

Windows 10 Pro crash - BSOD DPC - suddenly and consistently after months of being stable

Recommended Posts

This is irrating. I haven't changed anything on my main PC for ages. Now suddenly since yesterday I am getting BSOD multiple times per day - usually saying DPC failed occasionally on boot splash screen saying Kernal switch mode exception.

 

As far as I am aware all my drivers are totally up to date. Windows integrity scan elevated sfc /scannow returns no errors. But if I go away and leave my PC for 20 - 30 minutes a crash DPC is almost certain to happen. I haven't chnaged my power settings in ages. My main UPS just had new batteries installed and seems rock solid. Windows last did a major update about 1-2 weeks ago.

 

Any suggestion greatly appreciated!

Share this post


Link to post
Share on other sites

Win10 Pro here too on my MBP.

 

A quick search, seems it's been an issue around a while. But I do suspect it's likely not a single problem else would have been cured ages ago. Can be related to storage drivers, AHCI and the like.

One plausible hit http://www.thewindowsclub.com/dpc_watchdog_violation-blue-screen-in-windows-10

 

I'd suggest check the Bios settings relating to HDDs, AHCI mode etc. Maybe try what's suggested in the link. Do a Windows Update.

Share this post


Link to post
Share on other sites

Well this is great... run update and restart on mine, first update in little over a week. Been sitting at the "Getting Windows Ready" before restart message for nearly 15 minutes.

Share this post


Link to post
Share on other sites

Windows is fully up to date according to WIndows Update. In the last week four patches were applied - two security and two for adobe. ACHI hasn't changed on my motherboard as enabled for well over two years - I simply don't go into the BIOS ever. Two days ago I did a Windows startup recovery option - full memory test - no errors shown.

 

I have run disk checks on all 4 SSDs and 6 HDDs - all come back as ok... I also did a WIndows update check on all device drivers for all disks - it said the latest drivers were already installed. Machine has been rock solid for years and suddenly its incredibly flakey!

Edited by g__day

Share this post


Link to post
Share on other sites

Try turning off fast startup and hibernate.

https://www.tenforums.com/tutorials/4189-turn-off-fast-startup-windows-10-a.html

I was having weird BSOD issues with Win10 on my PC until I turned it off. With mine it seemed to be related to my HDD docking bay.

If I shut down with a HDD in the bay, removed the drive then booted windows it would eventually chuck a spaz.

I think this is because the hibernate file is used for the fast boot and this file contains info about what drives where connected at shutdown. Removing the drive and booting meant windows could not find the drive and got all sulky about it.

  • Like 2

Share this post


Link to post
Share on other sites

You added any new devices recently?

Sometimes its a dodgy driver associates with a new device.

Share this post


Link to post
Share on other sites

I agree with what AliAli suggested - found it myself but was too busy resolving the update issue and forgot to post it.

Can't hurt anything, easily reversed so worth a try.

Share this post


Link to post
Share on other sites

I haven't found anything suspicious in the event logs yet - which is annoying. And have just turned off fast start and will reboot now.

 

One thing that does seem to make the event happen a lot - walk away for the PC for 10 - 15 minutes and let it go into a different power state / more - so I guess that is an area to look into!

Share this post


Link to post
Share on other sites

Sigh - walked away for 5 mins - BSOD Deferred Procedure Call - rebooted - Kernel exception on WIndows SPlash screen before I went to select user to log in. Next attempt started fine. Event logs:

 

Session "P2PLog" stopped due to the following error: 0xC0000188

 

and earlier

 

Session "ReadyBoot" stopped due to the following error: 0xC0000188 ( so just upped the data collector file size from 20MB to 128MB)

Edited by g__day

Share this post


Link to post
Share on other sites

Have to wonder what's going on in those companies... probably come down to being a toxic update item. Though you generally hear about those fairly quickly.

Share this post


Link to post
Share on other sites

Seems to be - still trying things and going thru event logs. The behaviour seems to be if there is no keyboard activity / or no movie or game playing for about 3 minutes - Whammo - DPC crash. So something must be on an inactivity timer (presumably under Power settings - and it calls something possibly corrupted and Kerblamis my guess).

 

And there in the Log file is A timeout was reached (30000 milliseconds) while waiting for the Mezzmo service to connect. Now Mezzmo is a Media player - which I normally rarely run - no idea why something has set a 30 second timeout on this service or if its just a smoke screen. Another lead to trace down...

 

Also I see under Task Scheduler -> Task Scheduler Library -> Microsoft -> Windows -> .Net framework advice from folks saying to disable disable .NET Framework NGEN v4.30319 64 Critical

 

Also folk say to permanenetly turn off WIndows Defender - which even if set off in Setting Security - can still turn back on - so activiate the security policy that turns WIndows Defender off.

 

https://www.ghacks.net/2015/10/25/how-to-disable-windows-defender-in-windows-10-permanently/

Edited by g__day

Share this post


Link to post
Share on other sites

Might be Windows Search (what Indexing Service is now called). I just disable it, PITA having disk access going on so much for the little benefit it seems to bring.

You can disable that in the Computer Management -> Services panel.

 

It might be worthwhile firing up the activity monitor and select the disk tab. Maybe you'll get a glimpse of suspects before it Bsods.

 

I used Mezzmo for a while - it used to be really good in that it just used the windows directory info but they changed it to be like most other media servers, as in it'll annoyingly scan through the libraries you define to it and create it's own database of your media files. Often they also run as a service so will be activated any time changes occur to a file. I now use Serviio - the annoyance with it being that as soon as a file is created, moved, renamed within my video libary it scans through it to update it's metadata which prevents me doing anything for it for a little while.

Share this post


Link to post
Share on other sites

Will try that next. Just turned caching off on the SSDs - that's just a shot in the dark,

 

If I can't debug it I might try to evade it. Maybe a program I hear like move mouse might trick WIndows into never going into BSOD mode if it never thinks its idle?

Share this post


Link to post
Share on other sites

If you know the idle interval that the problem occurs at then cross-check with the advanced Power options. If something's near to that value, might be the culprit.

Share this post


Link to post
Share on other sites

Will try that next. Just turned caching off on the SSDs - that's just a shot in the dark,

 

If I can't debug it I might try to evade it. Maybe a program I hear like move mouse might trick WIndows into never going into BSOD mode if it never thinks its idle?

 

If you think it's a power related thing, a lot of event timers and such are reliant on monitoring C states.

See if you can turn off some of the more 'agressive' C states in the BIOS and see if it continues to offend.

 

Tons of devices wont 'sleep' unless the computer is low C

Share this post


Link to post
Share on other sites

Well I have turned off the disk caches - left Movemouse running plus a small 1 minute video looping on a minimised Windows Media Player - no crashes in a day - so one of these three helps matters. I will turn off Movemouse and see what occurs.

 

I already had the ReadyBoost data set increased from 20MB to 130MB - just put it up to 200MB for good measure.

 

Thanks all - detective work continues!

Share this post


Link to post
Share on other sites

What sort of device is Readyboost using? Personally I don't see much point in using it at all in these days of fast SSDs and cheap, plentiful Ram.

  • Like 1

Share this post


Link to post
Share on other sites

No idea either! BTW - stopped Move mouse and then Windows Media player and no crashes! So some change in the WIndows Update (possibly Anniversary edition) appears to really not like to have any caching enabled on SSDs.

 

I have four SSDs in this machine - so next I may try and selective turn it one to see if I can find one that make it crash and figure out why it does this. As far as I am aware each SSD has the latest firmware applied.

Share this post


Link to post
Share on other sites

What sort of device is Readyboost using? Personally I don't see much point in using it at all in these days of fast SSDs and cheap, plentiful Ram.

 

 

No idea either! BTW - stopped Move mouse and then Windows Media player and no crashes! So some change in the WIndows Update (possibly Anniversary edition) appears to really not like to have any caching enabled on SSDs.

 

I have four SSDs in this machine - so next I may try and selective turn it one to see if I can find one that make it crash and figure out why it does this. As far as I am aware each SSD has the latest firmware applied.

It's probably using one of the other SSDs. Turn it off as it is totally pointless if you have an SSD boot drive.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×