Jump to content
Forum upgrade is live! Read more... ×
Sign in to follow this  
Tunnel_Rat

Arma 3 Crashing "STATUS_HEAP_CORRUPTION"

Recommended Posts

Hi guys

I am at a loss why Arma 3 keeps crashing it will crash in any game mode at any time. The exit code it comes up with is 0xC0000374 - STATUS_HEAP_CORRUPTION

I have had no luck finding answers online and the only problem I can find with my PC is the C: drive is almost full. But Arma 3 is loaded on its own SSD drive with plenty of room.

I have uninstalled the game and all its mods, reinstalled them and it did nothing still crashing. I have saved a troubleshooting report for bohemia but am having problems uploading them on their website.

 

Anybody got any idea ?

Could a STATUS_HEAP_CORRUPTION have anything to do with Ram ?

 

thanks for any help.

 

Will

Share this post


Link to post
Share on other sites

Thanks man I did that and it did nothing so than I deleted the whole game and mods and reinstall it but same thing still crashes.

Its the only game I play its doing my head in. Just put in a ticket with bohemia hope they can work something out.

 

thx

Share this post


Link to post
Share on other sites

it may be on its own drive but it probably still uses the windows virtual memory which should be enabled on the c: drive despite some suggesting that you disable it with a ssd so just make sure its still enabled and windows managed

this guess is simply based on what you said about the error possibly being due to c: being full

 

is this the first time you installed arma or did something change after it had been working fine?

 

im enjoying playing arma3 antistasi coop at the moment so hope you get it sorted

Share this post


Link to post
Share on other sites

Been playing arma for a few years and this just started about 4 weeks ago. Cannot think of anything that changed other than my C: drive becoming pretty full.

So today I replaced my HDD with a bigger one cloned a new SSD 250GB to replace the 120GB so now have plenty of room. Got on Arma3 was playing for over an hour thinking sweet its all good than bang crashed again same old 0xC0000374 - STATUS_HEAP_CORRUPTION

My virtual memory is enabled.

 

I have no idea what the next step is

 

thanks for your help

Share this post


Link to post
Share on other sites

A few hits with a search but by reinstall without mods it sounds like this hint won't be much help https://forums.bistudio.com/forums/topic/199672-status_heap_corruption-0xc0000374/

 


In your arma launcher revert all options to default. There have been a lot of improvements so none of the options are really needed anymore but there's a conflict from those.

Share this post


Link to post
Share on other sites

 

0xC0000374 - STATUS_HEAP_CORRUPTION

 

Honestly, run a Memtest boot disk over night. It's not uncommon to find one program that kills a system. It might just happen to stress that specific 100mb of RAM that's 'sometimes faulty' until it actually faults.

Other games or apps might not have the exact, (random numbers) 1.2GB of textures to load to make sure that the next 100mb (which in this theory is bad) is constantly used as the most active chip.

 

Goodluck.

 

Curiously, kept an eye on heat?

Share this post


Link to post
Share on other sites

Thanks guys

I was thinking it could be a memory/ram problem but all the test I have run so far the ram shows up fine. I run the tests that Dasa linked (Thanks) and it came up fine. I will run the Memtest boot disk tonight.

Share this post


Link to post
Share on other sites

memtest isnt likely to find much its all but useless these days unless there is serious instability

use to be great

 

which test did you run? multile instances of hci is good for memory controller issues and probably good enough for ram if run overnight while the linux test is excellent for ram and if it doesn't find anything you can rule out the ram as a problem

Edited by Dasa

Share this post


Link to post
Share on other sites

Will I tried everything still just kept on crashing.

But I think its fixed now as it has not crash for days after the Arma 3 update. It would crash every game before so lets hope its fixed.

Thanks for all your help anyway guys always a great team on here.

 

thx

Rat

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×