Jump to content
Sign in to follow this  
Cybes

W10 15 March update broke my mouse

Recommended Posts

24 minutes ago, fliptopia said:

So is system restore not an option? 

And what antivirus if any have you had or do you have? 

 

It's an option, but last restore point is about a week of downloads ago.  I'm also pretty sure forced updates will just happily reinstall the broken shit anyway.

 

There's no AV on either of my machines except Defender.  It doesn't play well with others, and it's not that bad these days anyway, provided you don't do stupid things.

 

 

 

So, cheapshit mouse does in fact light up, so there's some sort of activity in the ports - just Windows not recognising it.  Could be  faulty memory, but I coulda sworn it was brighter last time I used it (9 months ago).  They surely can't have fubar'd things so badly the ports are undervolted.

 

Oh, and the laptop I've had to fall back on autoupdated last night as well.  That still works, fortunately - but it did take 30 minutes to start up.  (Not kidding!  I was sure it was frozen, but I was eating so let it sit.)

Share this post


Link to post
Share on other sites

There's every chance that the update will work properly the second time and not screw up your mouse again. 

 

Have you checked your update history to see what the update was? 

 

Share this post


Link to post
Share on other sites
49 minutes ago, fliptopia said:

There's every chance that the update will work properly the second time and not screw up your mouse again.

 

Considering that I've already rolled back the update and had it install again, I question your conclusion. 😜

 

I'm about ready to punt the fucking thing out the window (the RL one, with glass).  I guess that means my next step is "Fuck my downloads!" - one way or another.   And if it's still broken after that, I just might try Linux again.  Maybe it's ready this time.

 

 

 

Oh, and a DISM scan also turns up nothing.  And comparing the laptop's driver list (also rearranged by the update) reveals exactly the same driver config as the desktop unit.  I can see no reason why it should not work, but it doesn't.  And people ask why I got out of computing.

Share this post


Link to post
Share on other sites

I question why I stick with it almost daily. You could roll back and pause the update for a month... Maybe something will be fixed by then. 

Share this post


Link to post
Share on other sites

Just loaded March update on my work PC with zillion bit of software, seems happy.

Share this post


Link to post
Share on other sites
17 hours ago, fliptopia said:

I question why I stick with it almost daily. You could roll back and pause the update for a month... Maybe something will be fixed by then. 

 

Already tried rolling it back. It stayed broken (which I didn't know was possible).  So I let it reapply the patch, and that's still broken too.

 

3 hours ago, Jeruselem said:

Just loaded March update on my work PC with zillion bit of software, seems happy.

 

Most people - almost all - have had no problem.  Most who have had a problem get fixed by simply deleting the driver and letting redetect.  I am one of a tiiiiiiny group.

 

Knowing that does not make me happier.

Share this post


Link to post
Share on other sites

I do have the Logitech gaming mouse drivers loaded so it's not a normal set up at all, which might be why the monthly updates might not affecting my mouse driver.

Share this post


Link to post
Share on other sites
On 17/03/2019 at 8:12 PM, Cybes said:

 

It's an option, but last restore point is about a week of downloads ago.

 

Were you worried about losing actual stuff you've downloaded, or a week of updates ago?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×